cancel
Showing results for 
Search instead for 
Did you mean: 

Linux and Boot Issue

SOLVED
Go to solution
William Clark_9
Occasional Visitor

Linux and Boot Issue

I have a G1 ML370. Installing Linux 7.2
On Boot up, press F1 to Continue, or F10 for partition Utilites is displayed. I need to boot straight to Linux. How do I get around F1 Message?
9 REPLIES
Olivier Drouin
Trusted Contributor

Re: Linux and Boot Issue

I seen it on 2 cases.

You have a failed drive in your array.
or
the bios is set to another OS than linux. If it is the case, just change it.
William Clark_9
Occasional Visitor

Re: Linux and Boot Issue

I have 4 brand new 72.8GB Drives, and OS is pointed to Linux. Still having same issue.
Mark Grant
Honored Contributor

Re: Linux and Boot Issue

What happens when you press F1?

I presume your linux partition has the boot flag set.
Never preceed any demonstration with anything more predictive than "watch this"
William Clark_9
Occasional Visitor

Re: Linux and Boot Issue

I press F1 and it goes to the GRUB. It looks like the F1 message is part of the POST?
I could be wrong, and I will check the boot flag.
Vernon Brown_1
Frequent Advisor

Re: Linux and Boot Issue

I see that when I forget to remove the RedHat Linux install disk after installing.

Or; have you successfully installed Linux ?

William Clark_9
Occasional Visitor

Re: Linux and Boot Issue

I have not installed yet( this time), but have previously and had the same result. This was after I configured and went through the whole set up process.
I am now at the erase everything stage and working from there. I just want to make sure the configuration is correct before loading OS.
It goes through Array configuration, then into the F1 after raid confirmation.
Thanks,
Bill Wood_3
Respected Contributor
Solution

Re: Linux and Boot Issue

The F1 prompt is a result of the post test determining that there is something wrong or that some maintainance is required. If you correct the problem the F1 prompt will go away. Or you can diable the F1 Boot Prompt in the System Config utility. This selection is a part of the advanced features located in the configure hardware section. It can only be changed in advance mode. Advanced mode is entered by pressing ctrl-a at the main menu of the System Config Utility.
yu iu
Occasional Visitor

Re: Linux and Boot Issue

Hi,

After I pressed F10 to get into the setup menu and then I tried "ctlr-a" as suggested, but I didn't get any other menu to disable F1:boot. I wonder if "ctlr-a" also applied to HP xw6200 workstation. My setup menu already has an sub-menu called advance, but it doesn't have an option to disable F1.

I do see a message: "917-front audio is not connected". I don't care about audio feature and I have also disable the audio controller in the setup menu, which doesn't help, as the it still ask me to press "F1:boot". (I did tried to make sure that all the cables are connected to the mother board.)

Once F1 is pressed, the machine will be successfully booted.

Any suggestion?

Thanks.

- vicky
John Micheals
Occasional Visitor

Re: Linux and Boot Issue

To stop geting the 917 error message just short out pins 7 and 5 on the front audio header, You should not have to press f1 to Boot any more.
Cheers