cancel
Showing results for 
Search instead for 
Did you mean: 

MCA event occurred !

Jack Vo
Occasional Contributor

MCA event occurred !

Hi all,
I'm using rx7640 with Suse Enterprise Linux 10
Kernel 2.6.16.46-0.12-default

I see a warning messages for the network settings in /var/log/messages

"Warning: Could not set up default route via interface"
I settings the default gateway in /etc/sysconfig/network/routes is
default 10.74.232.6 - -

Is this wrong ? Or I must change to :
default 10.74.232.6 0.0.0.0 UG


# content in /var/log/messages
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8 done
Interface 'eth0' of device 'eth0' renamed to eth0
Don't use PERSISTENT_NAME any longer. See /usr/share/doc/packages/sysconfig/README.Persistent_Interface_Names
eth0 device: Intel Corporation 82546GB Gigabit Ethernet Controller (rev 03)
eth0 configuration: eth-id-00:22:64:34:4c:f2
eth0 IP address: 192.168.9.140/24
Warning: Could not set up default route via interface
Command ip route replace to default via 10.74.232.6 returned:
. RTNETLINK answers: Network is unreachable
Configuration line: default 10.74.232.6 - -
This needs NOT to be AN ERROR if you set up multiple interfaces.
See man 5 routes how to avoid this warning.
done
eth1 device: Intel Corporation 82546GB Gigabit Ethernet Controller (rev 03)
No configuration found for eth1 unused
eth2 device: Intel Corporation 82546GB Gigabit Ethernet Controller (rev 03)
eth2 configuration: eth-id-00:1a:4b:09:86:ec
eth2 Startmode is 'off' skipped
eth3 device: Intel Corporation 82546GB Gigabit Ethernet Controller (rev 03)
No configuration found for eth3 unused
eth4 device: Intel Corporation 82546GB Gigabit Ethernet Controller (rev 03)
eth4 configuration: eth-id-00:1a:4b:09:87:2a
eth4 Startmode is 'off' skipped
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: link is not ready
IPv6 over IPv4 tunneling driver
eth5 device: Intel Corporation 82546GB Gigabit Ethernet Controller (rev 03)
No configuration found for eth5 unused
cat: /sys/class/net/bond0/type: No such file or directory
bond0
Ethernet Channel Bonding Driver: v3.0.1 (January 9, 2006)
bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
bonding: bond0: setting mode to active-backup (1).
bonding: bond0: Setting MII monitoring interval to 100.
bond0 enslaving interfaces: eth2 eth4
ADDRCONF(NETDEV_UP): eth2: link is not ready
e1000: eth2: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex
bonding: bond0: making interface eth2 the new active one.
bonding: bond0: enslaving eth2 as an active interface with an up link.
ADDRCONF(NETDEV_CHANGE): eth2: link becomes ready
ADDRCONF(NETDEV_UP): eth4: link is not ready
e1000: eth4: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex
bonding: bond0: enslaving eth4 as a backup interface with an up link.
ADDRCONF(NETDEV_CHANGE): eth4: link becomes ready
bond0 IP address: 10.74.232.1/29 as bonding master done
Setting up service network . . . . . . . . . . . . . . done

# Output of the "route -n" command.
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.74.232.0 0.0.0.0 255.255.255.248 U 0 0 0 bond0
192.168.9.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 10.74.232.6 0.0.0.0 UG 0 0 0 bond0

If not, how can I stop the messages ???


Thanks
3 REPLIES
Jack Vo
Occasional Contributor

Re: MCA event occurred !

Hi all,
Sorry about the title. It must be "Warning: Could not set up default route via interface"
Matti_Kurkela
Honored Contributor

Re: MCA event occurred !

The problem is that the system attempts to set the default route before bond0 has started.

I'm not very familiar with SuSE 10, but I guess there might be a way to tell the system that this route is associated with bond0. That would stop the system to bring up the default route until bond0 has completed starting.

As your route -n command indicates, the system eventually sets up the route correctly. So the message is basically just "noise".

MK
MK
Jack Vo
Occasional Contributor

Re: MCA event occurred !

Thank you for your advance.