System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA1500 Unit 0 is NOT extended because of volume overlapping

Dominique Epp
Occasional Contributor

MSA1500 Unit 0 is NOT extended because of volume overlapping

I just expanded an MSA1500 RAID6 array from 1.2TB to 3TB. The array has 2 LUNs or Units: unit0 200GB and unit 1 1000GB. Trying to extend unit 0 using following cmd w/ the result:
CLI-1> extend unit 0 add_size=790000mb
The actual new volume size will be 994797MB.
Unit extension failed.
Unit 1 is being moved. Use 'show unit 1' to monitor progress.
Unit 0 is NOT extended because of volume overlapping!

The move of unit 1 lasted about 15hrs and I then repeated the same command, w/ exactly the same result: unit 1 is being moved again.

Any idea about what's happening ?
3 REPLIES
Pieter 't Hart
Honored Contributor

Re: MSA1500 Unit 0 is NOT extended because of volume overlapping

>>> MSA1500 RAID6 array <<<

check current config of your array/raid-volumes/units.
could be the new unit-0 size plus the raid-overhead is more than the free space on the volume.

maybe the "move" of unit-1 is started, but rolled-back because of insufficient space.
what's the output of show unit 0, show unit 1, show units?

Any reason why not to use ACU?
Dominique Epp
Occasional Contributor

Re: MSA1500 Unit 0 is NOT extended because of volume overlapping

I retried the command twice w/ always the same result (after 15 hrs each!). However, the 3rd time for some unknown reason and w/ no changes made whatsoever, it worked. Although yet another move was being announced, the message now was:
CLI-1> extend unit 0 add_size=790000mb
The actual new volume size will be 994797MB.
Unit 1 is being moved. Use 'show unit 1' to monitor progress.
Unit 0 is being extended. Use 'show unit 0' to monitor progress.

The unit 0 extension was successful !
Kirk Maule
Occasional Visitor

Re: MSA1500 Unit 0 is NOT extended because of volume overlapping

We are having similar problem with an MSA1000 when trying to extend LUN 0 when there is also a LUN 1 in-place.

We do not see the "Unit 1 is being moved" output.

Should we be seeing this output?
Cheers,
Kirk