cancel
Showing results for 
Search instead for 
Did you mean: 

NFS mount Permission denied

SOLVED
Go to solution
Rajendra prasad NVR
Frequent Advisor

NFS mount Permission denied

I had entered below line in /etc/exportfs
/var/opt/ignite/recovery/archives/ttux -anon=2,access=ttux
and exportfs -av.

When i try to mount from ttux it is giving error Permission denied.

But it work fine if i put/var/opt/ignite/recovery/archives/ttux -anon=2 and re-export it work fine.

My problem is exporting to every one is security breach. How to export to access nfs mount to a single system.

Thanks in advance.
10 REPLIES
Dennis Handly
Acclaimed Contributor
Solution

Re: NFS mount Permission denied

What HP-UX version are you using?
Specify the FQDN instead of just ttux.
shanmuhanandam
Regular Advisor

Re: NFS mount Permission denied

Hi,
Did you checked the hosts entry in NFS server.
you need to have the host entry for the client in /etc/hosts file on NFS server, in case if you don't have the DNS configured.

Thanks,
Shan.
Matti_Kurkela
Honored Contributor

Re: NFS mount Permission denied

On the Ignite server, run "nslookup ".

If the command cannot find the name "ttux", you may have a problem in the reverse mapping (IP -> name) records of your DNS. Ask your DNS administrator to fix that. As a workaround, you can add the name and IP address of ttux to /etc/hosts and try the command again.

Once nslookup can report the name of ttux when queried by IP address, your IP-to-hostname lookup works. You must use the _exact_ name reported by nslookup in your /etc/exports line: if nslookup reports "Name: ttux.company.com", you must specify "access=ttux.company.com", not just "access=ttux".

MK
MK
INH
Regular Advisor

Re: NFS mount Permission denied

Hello,

This is peculiar issue with net recovery...
make sure DNS entry is fine and working with forward and revers look up of rserver FQDN , IP. This should resolve the issue.

Regards,
INH
Knowledge is power
Rajendra prasad NVR
Frequent Advisor

Re: NFS mount Permission denied

It is working fine if remove anon=2,access=ttux
in /etc/exports that means to every one nfs share. But i want to know what is correct syntax to nfs share in ignite sever setup.

If i give share to every one it is working which lead to security issue.
Dennis Handly
Acclaimed Contributor

Re: NFS mount Permission denied

>I want to know what is correct syntax to NFS share in ignite sever setup.

Have you specified the FQDN instead of just ttux, as I said above?
Rajendra prasad NVR
Frequent Advisor

Re: NFS mount Permission denied

yes, i tried with FQDN same error. The os is 11.23 version.
Shibin_2
Honored Contributor

Re: NFS mount Permission denied

>> /var/opt/ignite/recovery/archives/ttux -anon=2,access=ttux

Your syntax is correct. Have you checked the permission of that directory ?

If you feel all fine, then try to change the option. Add following with the existing one.

rw=ttux,root=ttux

Final will be looks like this:

/var/opt/ignite/recovery/archives/ttux -rw=ttux,anon=2,access=ttux,root=ttux

Now try to re-export and try to mount.
Regards
Shibin
Viktor Balogh
Honored Contributor

Re: NFS mount Permission denied

Shibin wrote:
>root=ttux

this would also be a security leak... IMHO ignite doesn't require this...
****
Unix operates with beer.
Viktor Balogh
Honored Contributor

Re: NFS mount Permission denied

Rajendra,

you said that if you export the share to everyone it can be mounted without problems. That should clearly point to a name resolution problem. Post the o/p of:

# nsquery hosts ttux

nsquery is similar to nslookup but it works by using nsswitch.conf which is the same way name resolution works with nfs.
****
Unix operates with beer.