cancel
Showing results for 
Search instead for 
Did you mean: 

NFS mount on boot

SOLVED
Go to solution
Spark_2
Frequent Advisor

NFS mount on boot

Hi,

The NFS mount point didnt mount automatically during reboot and had to be later mounted manually.
How shall I go about investigating
8 REPLIES
Matti_Kurkela
Honored Contributor

Re: NFS mount on boot

First find the error message from the system logs: /etc/rc.log and /var/adm/syslog/syslog.log.

Then verify that the NFS mount point is correctly entered in /etc/fstab: if this is the case, the filesystem should be mountable with a simple "mount " with no additional parameters.

MK
MK
Hakki Aydin Ucar
Honored Contributor
Solution

Re: NFS mount on boot

Additionally check /etc/rc.config.d/nfsconf file if it is enable or not ?
Spark_2
Frequent Advisor

Re: NFS mount on boot

# more /etc/rc.log| grep nfs
Output from "/sbin/rc2.d/S400nfs.core start":
Output from "/sbin/rc2.d/S430nfs.client start":
NFS_CLIENT not set to one in /etc/rc.config.d/nfsconf, exiting.
Output from "/sbin/rc3.d/S100nfs.server start":
NFS_SERVER not set to one in /etc/rc.config.d/nfsconf, exiting.


setting NFS_CLIENT to 1 should solve the problem...hope I am correct
SUDHAKAR_18
Trusted Contributor

Re: NFS mount on boot

have you added the filesystem in /etc/fstab ?
saber_lahlib
Occasional Advisor

Re: NFS mount on boot

View the contents of /etc/fstab if there is the entrance to the automatic Mount

Host_name:/fs /fs_local nfs ...

Also look at the dmesg if there are any error messages.
Dave Olker
HPE Pro

Re: NFS mount on boot

Yes, if NFS_CLIENT is not set to 1 the startup script will never get to the logic of mounting NFS filesystems in /etc/fstab. Once you set NFS_CLIENT=1 it should work, assuming your /etc/fstab syntax is correct. The way you can tell without rebooting is to issue the command:

# /sbin/init.d/nfs.client start

and see if the NFS filesystem is mounted as you desired.

Regards,

Dave

Re: NFS mount on boot

Do u have any other NFS volumes exported to this host? if yes, How about them?
If this is the only one NFS volume and doesnt get mounted automatically , i would suggest for the following ,

make sure in /etc/rc.config.d/nfsconf,

NFS_CLIENT=1
NUM_NFSD=16
NUM_NFSIOD=16

also, after the reboot check these process are started automatically or not
/usr/sbin/nfsd , /usr/sbin/rpc.mountd , /usr/sbin/rpcbind


Cheers,
Ranoop
Spark_2
Frequent Advisor

Re: NFS mount on boot

NFS_CLIENT parameter was set to 1. Hope to see thigs working fine after next reboot. Thank you all for your time !