HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

NFS permission problem with ignite

 
SOLVED
Go to solution

NFS permission problem with ignite

Hi,
I am trying to add a new client to my ignite server, and the add_new_client script fails with permission denied errors from the mount.

The client in this case is 11iv2 with the latest recovery tools, and the ignite server 11iv1.

Manually trying the mount also fails.
On the ignite server, in /etc/exports I have "/var/opt/ignite/clients anon=2", which should make root be treated as UID=2 (bin). I have checked and bin has UID 2 on both client and server, but this still fails.
The permissions on the ignite server of /var/opt/ignite/clients is 755 (bin:bin)

Am I missing something here? It works if I put access= in exports, but surely I shouldnt have to do this for all new clients?

Thanks in advance for any pointers..

Giles
7 REPLIES
Avinash20
Honored Contributor
Solution

Re: NFS permission problem with ignite

/var/opt/ignite/clients -anon=2
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: NFS permission problem with ignite

Try removing -anon=2
"Light travels faster than sound. That's why some people appear bright until you hear them speak."

Re: NFS permission problem with ignite

I will double check whether I have the "-anon=2" or whether I have "anon=2" as soon as I am back in the office... I wrote this post on getting home - so I cannot check right now but I am fairly certain I have -anon=2 and my original post had omitted the "-" in error...

I'll check and confirm tomorrow.. points to follow once I sort it.
Ivan Krastev
Honored Contributor

Re: NFS permission problem with ignite

From the man page of exports - http://docs.hp.com/en/B9106-90011/exports.4.html

"An empty access= list allows all machines to mount the specified mount point."


For our servers all clients are listed in the exports file.

regards,
ivan
Avinash20
Honored Contributor

Re: NFS permission problem with ignite

Hi,

You could try by mentioning the following in /etc/exports

/var/opt/ignite/clients
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
sujit kumar singh
Honored Contributor

Re: NFS permission problem with ignite

Entries for /etc/exports in 11iv1 and11iv2 should look kilike this

/var/opt/ignite/clients -anon=2
/var/opt/ignite/archives -anon=2

Apart from that the client specicic option can be added as
/var/opt/ignite/archives -anon=2,access=client1:client2


do an
#exportfs -au
#exportfs -a

Entries for 11iv3 /etc/dfs/dfstab is like this

share -F nfs -o anon=2 /var/opt/ignite/clients
share -F nfs -o anon=2 /var/opt/ignite/archives
share -F nfs -o anon=2 /var/opt/ignite/clients
share -F nfs -o anon=2 /var/opt/ignite/archives


regards
Sujit

Re: NFS permission problem with ignite

As pointed about, I had missed off the "-" from anon=2. After adding that it is all working again :)

Thanks all