cancel
Showing results for 
Search instead for 
Did you mean: 

NFS portmap problem

Bengt Nilsson_2
Regular Advisor

NFS portmap problem

Compaq DS10, tru64v4.0F
At boot, just after the nfs shares in fstab have been mounted, the system hangs for a while saying:
"NFS portmap: RPC Port mapper failure - RPC: Timed out"

What could be the reason for this?

Eventually it continues to boot.
After boot, all seems normal.



BN

4 REPLIES
Rob Leadbeater
Honored Contributor

Re: NFS portmap problem

Hi,

I'll take a guess at some sort of name resolution problem. Do all of the NFS mounts actually mount ?

Cheers,

Rob
Bengt Nilsson_2
Regular Advisor

Re: NFS portmap problem

Yes, they do.
/etc/resolv.conf seems to be correct.
Are there other supplementary settings that may be in conflict?

Rob Leadbeater
Honored Contributor

Re: NFS portmap problem

Hi,

What switch infrastructure are you connected to ?

I was troubleshooting an XP1000 booting over the LAN recently and noticed that the NIC goes up and down 2 or 3 times during the boot. The Cisco switch I was connected to was consequently stopping traffic being passed so the boot failed.

It sounds like you have a similar situation... Although you don't say how long "eventually" or a "while" is...

Cheers,

Rob
Bengt Nilsson_2
Regular Advisor

Re: NFS portmap problem

Sorry folks, I goofed.
I had three NFS mount lines in /etc/fstab to a non-existent machine, thus the timeout.
With the lines removed, it boots without delay.
Again, sorry to have taken your time.

BN