System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

NIC inactive problem in RHEL ES 4.5 in BL460c server

SOLVED
Go to solution
Jeeshan
Honored Contributor

NIC inactive problem in RHEL ES 4.5 in BL460c server

HI all

I'm facing a weired problem. I have a 7000 blade encloser consisting of BL460C blade server. And the OS is RHEL ES 4.5. All servers consisting 2 NIC card. One NIC card is has 172.16.110.x series and another one is 172.16.111.x series.

Primary IP is 172.16.110.x series. When I ping primary IP it replying normally. But whenever I ping my secondary NIC it comes after 20-30 sec.

Not only that, most of the time I found the secondary NIC inactive.

Why the secondary NIC goes inactive? How can I resolve this?
a warrior never quits
10 REPLIES
Ivan Ferreira
Honored Contributor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server

Probably, you are confusing your kernel with the route tables, when you talk about "series" are you talking about network I suppose, but the network mask is not stated, if it's using the default network mask, both interfaces are in the same sub network that could cause that kind of problems.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Prasu
Frequent Advisor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server

Hi Ahsan,

check nic driver. As you said the second nic goes inactive, it seems that problem is with driver/kernel mismatch..


Reagrds
Prasu
skt_skt
Honored Contributor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server

inactive mean link shows down to the interface? DO you see any related logs on messages? what about the speed/dupex/negotiation? Is the MAC shows correct?
Jeeshan
Honored Contributor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server

>>inactive mean link shows down to the interface?
yes

>>DO you see any related logs on messages?
NO
>>what about the speed/dupex/negotiation?
Its ok

>>Is the MAC shows correct?

Yes
a warrior never quits
skt_skt
Honored Contributor
Solution

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server


link not detected is the problem ; Unless the card see the cable is connected its not going to work; Did u try a loop back test to the port in question? What trouble shooting/testing done so far?
Jeeshan
Honored Contributor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server


>>Did u try a loop back test to the port in question?
yes

>>What trouble shooting/testing done so far?
nolthing, just wanna do what i already told earlier.

my question is, does it related to BLADE server on board cisco swith with my external cisco switch?

a warrior never quits
~sesh
Esteemed Contributor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server

This could be a hardware / interconnect connectivity issue. You mention that you have 2 NICs. I would assume that you are using 1 mezzanine optional NIC apart from the integrated one.

In this case, its important to know what interconnects you have installed. If h/w setup is fine, then probably you can flash the f/w (firmware) for the NIC you have an issue and check if you have an update for the NIC drivers.
Jeeshan
Honored Contributor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server

actually what is happening i don't understand. really weired.

one thng i have to clear. From blade server switch, 2 upload cables are connected to external cisco switch. I'm concernig about the onboard cisco switch STP protocol is conflicting with the external cisco switch.

anyone supporting me?
a warrior never quits
Jeeshan
Honored Contributor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server

why my another NIC goes down? i'm still seek for this solution.


hope to hear from you soon.
a warrior never quits
Jeeshan
Honored Contributor

Re: NIC inactive problem in RHEL ES 4.5 in BL460c server

thanks all guyz. i have solved this problem using multihome linux configuration.
a warrior never quits