cancel
Showing results for 
Search instead for 
Did you mean: 

NIC speed set

 
SOLVED
Go to solution
Jayraj
Frequent Advisor

NIC speed set

Hi All,

How to set NIC speed 100/1000 etc, and how to set FDX/HDX mode.
6 REPLIES
Michal Kapalka (mikap)
Honored Contributor

Re: NIC speed set

hi,

use lanadmin

mikap
Pete Randall
Outstanding Contributor
Solution

Re: NIC speed set

This is a direct quote from Bill Hassell, because "nobody says it better":

+++++++++++++++++++++++++++++++++++++++++
To set the negotiation and speed options as static values, edit
the appropriate LAN config file in /etc/rc.config.d. The file
name depends on which LAN cards you have. Use the comand:

# ls /etc/rc.config.d/hp*conf

to see the config files. They correspond to the driver used for
the LAN card:

btlan hpbtlanconf
btlan0 hpeisabtconf
btlan1 hpbasetconf
btlan3 hpbase100conf
btlan4 hpgsc100conf
btlan5 hppci100conf
btlan6 hpsppci100conf
igelan hpigelanconf
iether hpietherconf
?????? hpetherconf
?????? hpgelanconf

To set 100 Mbits and full-duplex, use 100FD on the line with SPEED=
Note that each LAN card that uses the same driver will need an entry
and these are actually script arrays so the first instance of a
btlan3 LAN card will be 0 and the hpbase100conf entry will be:

HP_BASE100_SPEED[0]=100FD

(and the next 3 would be:

HP_BASE100_SPEED[1]=100FD
HP_BASE100_SPEED[2]=100FD
HP_BASE100_SPEED[3]=100FD

Repeat for other LAN cards based on their driver.

To view the current LAN setting:lanadmin -x 0

(where 0 is the card's instance or PPA number, found with lanscan).

To change the card setting without a reboot, use:

# lanadmin -X 100FD 0

Note that 100 half-duplex is the default value when negotiation at
100 bits fails and unless the switch is set the same, high error
rates and very low throughput will be the result.
+++++++++++++++++++++++++++++++++++++++++

The only thing I would add is that the newer Gigabit cards should be set to autonegotiate. Trying to force them to 1000 will not work.


Pete

Pete
johnsonpk
Honored Contributor

Re: NIC speed set

Hi ,

use lanadmin command
#lanadmin -S for setting the speed

#lanadmin -X for setting the driver specific options

Rgds
Johnson
Matti_Kurkela
Honored Contributor

Re: NIC speed set

Pete Randall covered everything regarding 11.23 and older.

With HP-UX 11.31, you can also use the new "nwmgr" command or the menu-based "ncweb".

For gigabit interfaces, autonegotiation is a mandatory part of the interface standard and cannot really be switched off. This is because gigabit requires some additional parameters for each gigabit link (clock source and master/slave role selection), and these are chosen using autonegotiation.

Some devices (for example, Cisco switches) offer a way to "disable autonegotiation" with 1000 Mbps interfaces, but it does not really disable autonegotiation: it just makes the device reject any negotiation answers other than the desired one. In other words, it makes the autonegotiation say: "1000 Mbps full duplex or nothing at all!"

MK
MK
Sajjad Sahir
Honored Contributor

Re: NIC speed set


Dear Swaraj

lanadmin is the command. please see the links

http://docs.hp.com/en/J4240-90046/ch04.html

thanks and regards

Sajjad Sahir
Bill Hassell
Honored Contributor

Re: NIC speed set

Just to clarify a bit:

You can use lanadmin but the changes are temporary and will revert back on reboot. Make the changes permanent in the /etc/rc.config.d driver files.

You *must* know the switch setting when changing speed and duplex. Autonegotiation can fail at certain cable lengths (about 20-40 meters) for 100Mbit links and this causes the card to be set to half duplex. This is very bad for performance (20:1 reduction in speed which massive errors reported in lanadmin). If the switch is set to 100auto and your card is set to 100auto, yet the reported speed/duplex from lanadmin -x is 100HD, then change BOTH sides to turn off autonegotiation and force 100FD.

Note that you cannot make a 100Mbit card run at 1000Mbit. 1000Mbit cards and switches should both be set to 1000auto as mentioned above.


Bill Hassell, sysadmin