NIS

 
SOLVED
Go to solution
Tarek
Super Advisor

NIS

Hi..
i'm adding a NIS client. It's on a different subnet mask of the NIS master. To see the NIS master i have forced the client, modifying /etc/rc.config.d/namesvrs
YPBIND_OPTIONS="-ypset"
YPSET_ADDR="NIS_MASTER_SERVER_IP"
Without these options, i saw that the client doesn't work in NIS, i had a message like this:
NIS domain domain_name not bound.
Putting those options it works. My doubt is, if my nis master server is down, does the client switch to the slave or not, cause of forcing..
if it doesn't, is there any way to set somewhere subnet mask?
5 REPLIES 5
Ravi_8
Honored Contributor

Re: NIS

Hi tarek
propably your client may not binding to the NIS server domain, check whether have u specified the domain name in client.
which os does client is in?

later
ravi
never give up
Tarek
Super Advisor

Re: NIS

Ravi..i have set the NIS domain on the client:
/usr/bin/domainname nis_domain_name
Then i put it in the /etc/rc.config.d/namesvrs.
I think the problem regards the subnet. In fact any client under the same subnet of the nis master server works perfectly without -ypset option.
RAJESH GANGADHARAN
Regular Advisor

Re: NIS

hi tarek
if u'r NIS server is in another subnet , u have to give the -ypset option, it's better have one slave NIS slave server in every subnet , in that case there is no need of giving -ypset option.
raj
Let the choices you make today be the choices you can live with tomorrow.
Shannon Petry
Honored Contributor
Solution

Re: NIS

You have to understand the default mechanisms for NIS binding to understand why you have to use the ypset option.

It has nothing to do with the servers availability, but rather how the NIS client is looking for a server.

In standard NIS bindings, the client sends out a broadcast on its own broadcast address. A server has to be able to read this, and reply back for the negotiation of the connection. Since your server has a different broadcast address than the client, the broadcast for a server is not heard, so the server can not reply back.

Solutions:
1. Do as you already have and force ypbind to set to the server on the other subnet.
2. Create a larger subnet to encompass both networks, and propogate this netmask to all of your hosts.

Regards,
Shannon
Microsoft. When do you want a virus today?
Alan Riggs
Honored Contributor

Re: NIS

You might also try making the client a slave server. I generall maintain a slave under each subnet of my NIS domains. It makes adding new clients easier and protects each subnet against network communications issues with the master.