HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

NOQUEUE: low on space (have 0, SMTP-DAEMON needs 101 in /var/spool/mqueue)

 
vasanth_2
Frequent Advisor

NOQUEUE: low on space (have 0, SMTP-DAEMON needs 101 in /var/spool/mqueue)

Hello all,

We are getting the above message and not able login into the server/console. Please suggest Urgent.

Thanks in advance
Vasanth
4 REPLIES

Re: NOQUEUE: low on space (have 0, SMTP-DAEMON needs 101 in /var/spool/mqueue)

You may have to boot in single user mode to free up space in /var/.

You may want to use "cleanup -c 1" to free the superseded patch save area.
Mel Burslan
Honored Contributor

Re: NOQUEUE: low on space (have 0, SMTP-DAEMON needs 101 in /var/spool/mqueue)

In some cases, from the console, you still can type your username and password, preferably root, very carefully without seeing the letters you are typing, because of the torrent of messages dumping to your console screen.

once you are in, try to clean up your mail queue directory by removing the files in it. Again without seeing what you are typing again, type this command:

rm /var/spool/mqueue/*

and sit down and wait for the command to clean it up.

also, you might want to kill any sendmail processes, dumping more messages into the queue, before starting this filesystem cleanup.

In more than 50% of such cases, this approach helped me, but as previously suggested, there always is the booting to the single user mode option.

Good luck
________________________________
UNIX because I majored in cryptology...
vasanth_2
Frequent Advisor

Re: NOQUEUE: low on space (have 0, SMTP-DAEMON needs 101 in /var/spool/mqueue)

Hi Mel,

Thank you for your valuable reply. I tried logging to server through console, host, ftp, sftp, ssh but nothing worked. Finally rebooted the server (not is single user mode), and found things were normal.

The issue may be with the sendmail which was piling up the undeliverable mails under /var/spool/mqueue. After the reboot the sendmail services refreshed and / filesystem is normal. No action taken.

Thanks
Vasanth
vasanth_2
Frequent Advisor

Re: NOQUEUE: low on space (have 0, SMTP-DAEMON needs 101 in /var/spool/mqueue)

closing the thread