cancel
Showing results for 
Search instead for 
Did you mean: 

Nagios installation

sandeep mathur
Respected Contributor

Nagios installation

I have completed the installation steps.
But when entering web interface am getting this type of error.

The requested URL /nagios/cgi-bin was not found on this server.
Apache/2.2.0 (Fedora) Server at 192.168.1.148 Port 80
how to overcome this error.
Please help me out. points assured.Thanks in advance.
7 REPLIES
Ivan Ferreira
Honored Contributor

Re: Nagios installation

How did you installed nagios?

That means that you have a problem with the installation directory and the apache configuration. Check your nagios alias in /etc/httpd/conf and your installation directory.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
sandeep mathur
Respected Contributor

Re: Nagios installation

I have followed steps that are required for installation of nagios in linux.
I have installed it on linux.
can i change the port of nagios how can i change it
Ervinck Kevin
Valued Contributor

Re: Nagios installation

please post your httpd.conf file (in attachment), then we can review your configuration.
Colin Topliss
Esteemed Contributor

Re: Nagios installation

This is using source code downloaded from www.nagios.org as opposed to the rpms (which are always a bit behind the latest). Your installation may differ slightly if you used rpms.

Apache2 config for nagios:

testserv:/etc/apache2/conf.d # cat nagios.conf
ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/

AllowOverride AuthConfig
Options ExecCGI
order deny,allow
deny from all
allow from all


Alias /nagios/ /usr/local/nagios/share/

AllowOverride AuthConfig
Options None
order deny,allow
deny from all
allow from all


I have htpasswd.users file set up under /etc/apache2/secrets for access to Nagios. Don't forget the associated .htacces file.

A listing of the installation directory.

testserv:/ # ls -l /usr/local/nagios
total 2
drwxrwxr-x 7 nagios nagios 192 Nov 1 2006 .
drwxr-xr-x 15 root root 368 Nov 1 2006 ..
drwxrwxr-x 2 nagios nagios 184 Nov 1 2006 bin
lrwxrwxrwx 1 root root 11 Nov 1 2006 etc -> /etc/nagios
drwxr-xr-x 2 root root 1936 Oct 2 2007 libexec
drwxrwxr-x 2 nagios nagios 584 Nov 1 2006 sbin
drwxrwxr-x 9 nagios nagios 392 Nov 1 2006 share
drwxrwxr-x 4 nagios nagios 320 May 25 15:46 var

The URL to use to access nagios (note the trailing '/'):

http://testserv/nagios/
Ciro Iriarte
Valued Contributor

Re: Nagios installation

Try replacing:

"ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/"

with:

"ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin/"
sandeep mathur
Respected Contributor

Re: Nagios installation


Thanks for ur help.i got the solution.
Steve Post
Trusted Contributor

Re: Nagios installation

Points assured huh?