System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Need help on backup script on HP-UX

SOLVED
Go to solution
Gaby1110
Frequent Advisor

Need help on backup script on HP-UX

Hi,
I am attaching a backup script(create_archive) here which we were using on HP-UX PA-RISC 11.11 system but now we are migrating to HP-UX Itanium 11.31 system. This script is working fine on Itanium as well but when it finish the backup it is not coming back to # prompt. But when we see the log file it says "make_net_recovery completed successfully!".

Please find below what we are getting.I have to do ctrl+c to come back to # prompt. Please let me know what needs to be added in the script so that when backup is completed we get the # promt .

# ./create_archive

Checking version...
Archiving started...Thu Sep 10 01:15:35 PDT 2009
0



(Interrupt -- one more to kill letter)


< root@: /usr/local/bin > [vi: (root) pts/1]
#


Thanks in advance.
Gaby
4 REPLIES
Gaby1110
Frequent Advisor

Re: Need help on backup script on HP-UX

Sorry , I forgot to attach the script. Attaching the same now
Roland Piette
Regular Advisor
Solution

Re: Need help on backup script on HP-UX

Hi Gaby,

Line 53 & 54 give the problem !

line 53 : mailx -s "Net archive creation completed on `hostname`" $MAILLIST
line 54 : < /dev/null

line 54 is the continuation of the line 53 so you need to add a \ character at the end of the line or join the line 54 to the line 53.

Actually mailx is waiting on stdin to complet the body of your message. Your script doens't reach the line 54 ! < /dev/null is needed to close the stdin. So they must be part of mailx.

Regards,
Roland
Gaby1110
Frequent Advisor

Re: Need help on backup script on HP-UX

Thanks a lot Roland...

Will allocate points..
Roland Piette
Regular Advisor

Re: Need help on backup script on HP-UX

Thanks Gaby