System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Need to extend /dev/vg00/lvol3 "/" mount point

Joe Profaizer
Super Advisor

Need to extend /dev/vg00/lvol3 "/" mount point

Below is the output of my lvdisplay for /dev/vg00/lvol3:
# lvdisplay -v /dev/vg00/lvol3
--- Logical volumes ---
LV Name /dev/vg00/lvol3
VG Name /dev/vg00
LV Permission read/write
LV Status available/syncd
Mirror copies 1
Consistency Recovery MWC
Schedule parallel
LV Size (Mbytes) 208
Current LE 13
Allocated PE 26
Stripes 0
Stripe Size (Kbytes) 0
Bad block off
Allocation strict/contiguous
IO Timeout (Seconds) default

--- Distribution of logical volume ---
PV Name LE on PV PE on PV
/dev/dsk/c2t1d0s2 13 13
/dev/dsk/c2t0d0s2 13 13

--- Logical extents ---
LE PV1 PE1 Status 1 PV2 PE2 Status 2
00000 /dev/dsk/c2t1d0s2 00275 current /dev/dsk/c2t0d0s2 00275 current
00001 /dev/dsk/c2t1d0s2 00276 current /dev/dsk/c2t0d0s2 00276 current
00002 /dev/dsk/c2t1d0s2 00277 current /dev/dsk/c2t0d0s2 00277 current
00003 /dev/dsk/c2t1d0s2 00278 current /dev/dsk/c2t0d0s2 00278 current
00004 /dev/dsk/c2t1d0s2 00279 current /dev/dsk/c2t0d0s2 00279 current
00005 /dev/dsk/c2t1d0s2 00280 current /dev/dsk/c2t0d0s2 00280 current
00006 /dev/dsk/c2t1d0s2 00281 current /dev/dsk/c2t0d0s2 00281 current
00007 /dev/dsk/c2t1d0s2 00282 current /dev/dsk/c2t0d0s2 00282 current
00008 /dev/dsk/c2t1d0s2 00283 current /dev/dsk/c2t0d0s2 00283 current
00009 /dev/dsk/c2t1d0s2 00284 current /dev/dsk/c2t0d0s2 00284 current
00010 /dev/dsk/c2t1d0s2 00285 current /dev/dsk/c2t0d0s2 00285 current
00011 /dev/dsk/c2t1d0s2 00286 current /dev/dsk/c2t0d0s2 00286 current
00012 /dev/dsk/c2t1d0s2 00287 current /dev/dsk/c2t0d0s2 00287 current

I have all my lvols on vg00 mirrored. I tried running:
pvmove -n /dev/vg00/lvol4 /dev/dsk/c2t1d0s2 /dev/dsk/c2t0d0s2
pvmove: Not enough free physical extents available.
Logical volume "/dev/vg00/lvol4" could not be extended.
pvmove: Cannot find a free physical extent for logical extent 0
of logical volume "/dev/vg00/lvol4".
Failure possibly caused by strict allocation policy

I tried this to free up contiguous space on /dev/dsk/c2t1d0s2 so I could possibly extend /dev/vg00/lvol3. I planned on doing this for lvol4 and lvol5 also.

I believe all my /dev/vg00/lvols have an allocation of strict. And all of the lvols are mirrored. I have plenty of space remaining on my VG to extend lvols, but I'm a bit confused on how to get this process started.
This is an rx4640 running 11.23.

Please advise.

Thanks,

..Joe
16 REPLIES
Pete Randall
Outstanding Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Joe,

/, /stand and swap need to be contiguous. Therefore, the only way to accomplish this is either to re-install or to use Ignite to create a make_tape_recovery backup and restore from that, resizing as you go.


Pete

Pete
MarkSyder
Honored Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

You can only extend / from an ignite backup. But / is usually small and shouldn't need increasing - look for files that should be elsewhere or shouldn't be there at all. The usual suspect is an incorrectly typed file in /dev/rmt: a large text file when you actually wanted to do a backup to a tape drive.

Mark Syder (like the drink but spelt different)
The triumph of evil requires only that good men do nothing
TwoProc
Honored Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Probably the easiest thing to do at this point is to create an ignite backup tape, and then reinstall using the tape. It will give you the opportunity to cut up disks most any way you'd like before putting your OS and all files back to exactly where you were from your backup (including patches, configurations, hosts, etc). It really does it all for you.
We are the people our parents warned us about --Jimmy Buffett
Simon Hargrave
Honored Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Since all your LV's are mirrored there will be the same amount of space used on both the PVs. You should not need to pvmove any data from one PV to the next.

Have you tried just extending lvol3?

But before you do, consider whether you need to extend lvol3 (/)? Yours is 200Mb which is ample for an 11i installation. Check for large files in / with for example: -

find / -xdev -size +5000

This will look for files >5Mb in root filesystem. Look particularly for core files etc, or if someone has created a real file in /dev (/dev/rmt/0 is a common mistake made).
baiju_3
Esteemed Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Hi Joe ,

Do pvdisplay -v for all the disks in the VG00.

Check whether you can leave the disk containig /,root and swap untouched , migrate the PVs on other disk and remove it .


Ragards,
baiju.
Good things Just Got better (Plz,not stolen from advertisement -:) )
Jakes Louw
Trusted Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

I agree with the ignite method: there are ways to split off the mirrors and resize the mirror disks, then sync back in reverse, but that's for experts ;-)
Trying is the first step to failure - Homer Simpson
Steven E. Protter
Exalted Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Shalom,

Simply put, you can't extend the root filesytem due to the contiguity requirements. The Ignite method is a method I've used several times with success. It does require downtime, but it is supported by HP so if you get into trouble, HP has your back.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
James R. Ferguson
Acclaimed Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Hi Joe:

As noted, Ignite is the guaranteed way to be able to resize logical volumes like '/'.

I would question why you need to do this, however. The root ("/") logical volume should be devoid of files and directories other than (notably) '/dev', 'etc/', '/sbin' and '/stand'. The 200MB logical volume you have should be adequate. Depending on the OE you are running, 208-223 MB is standard and wiil run about 78-83% utilization of that space.

If you have placed files or directories here that should exist elsewhere, moving those files and directories would obviate the need to expand "/".

Regards!

...JRF...
Joe Profaizer
Super Advisor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Thanks all. It looks as if there are log files created under /etc. Primarily the Navisphere agent log for our EMC SANs.

/etc/Navisphere/log/navimon.log

This is standard with EMC. I have also run into an issue with "/" or maybe it was "/var" being too small when I install patch bundles and it fails disk space analysis.
Geoff Wild
Honored Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

As others have said - ignite is the preferred/best way to resize your vg00.

I have exteneded root when the next lvol was home - by creating a new /home, lvremoving the old home lvol, then extending /

Rgds...Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
Joe Profaizer
Super Advisor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Thanks.
My next lvol is mount point /tmp. I could dismount it and move it, however I have the following processes active. Can I shut these down and restart them after I move /tmp?

# fuser -uc /tmp
/tmp: 1112o(root) 1121o(root) 1129o(root) 1145o(root) 1765o(root)

(stlpora4:/)
# ps -ef|grep 1112
root 1112 1 0 Jan 21 ? 0:00 /usr/sbin/hp_unixagt
root 10526 8494 0 11:43:05 pts/0 0:00 grep 1112
(stlpora4:/)
# ps -ef |grep 1121
root 1121 1 0 Jan 21 ? 0:03 /usr/sbin/ipv6agt
root 13395 8494 0 11:43:19 pts/0 0:00 grep 1121
(stlpora4:/)
# ps -ef|grep 1129
root 1129 1 0 Jan 21 ? 0:04 /usr/sbin/mib2agt
root 13406 8494 0 11:43:28 pts/0 0:00 grep 1129
(stlpora4:/)
# ps -ef|grep 1145
root 1145 1 0 Jan 21 ? 0:00 /usr/sbin/trapdestagt
root 13410 8494 0 11:43:37 pts/0 0:00 grep 1145
(stlpora4:/)
# ps -ef|grep 1765
root 1765 1 0 Jan 21 ? 0:12 /opt/VRTSob/bin/vxsvc -r /opt/VRTSob/config/Registry
root 13412 8494 0 11:43:43 pts/0 0:00 grep 1765


Thanks!
James R. Ferguson
Acclaimed Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Hi Joe:

If the log '/etc/Navisphere/log/navimon.log' is large and giving you space constraints, consider making it a symbolic link to a file that resides (for instance) in '/var'.

Regards!

...JRF...
Lolupee
Regular Advisor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Joe,

follow this step. create another lvm for the lvol4 and lvol5. Then tar the data unto the newlvols after mounting. If those file systems lvol4 and lvol5 are not being used, then juggle the names around and i.e filesystems names, umount lvol3 and lvol4. then delete to free space and extend your lvol3.

This will only work if you are sure the next space to lvol3 is actually being used by lvol4 and lvol5.

You cannot move files since you have only 2 drives that are mirrored. This lvol4 and lvol5 are presently on those drives.
The other way which is not advisable is to remove the mirrors on lvol3 and lvol4.

Then the trickish part and this must be carefully done.
remove lvol4 and lvol4 mirror. lvol3 reside in drive A and lvol4 reside in drive B
Since you have removed lvol4 from drive A, the nest sectors would be free for lvol3 up to the space for lvol4 size. this is very clumsey because you would not be able to mirror the lvol3 which is important to file system again.

So the best advise is to use the former.

create new FS for lvol4 and lvol5.
tar content of lvol4 and lvol5 to the new FS
umount lvol4 and lvol5 and confirm newlvols are working well.

remove lvol4 and lvol5
extend lvol3 upto the size of lvol4 and lvol5.

You must not delete lvol4 before creating newlvol5, else the newlvol5 would occupy the space you just created.

However, you may extend lvol3 after deleting lvol4.

hope you are not confused.
Nguyen Anh Tien
Honored Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

There is no way to extend / in HP-UX 11.11 and below verion because / file system is HFS type.
If you use HP-UX 11.23 you can extend it online
The best way to extend it is ignite:
1, Ignite all lvm in vg00
2, restore it. At beginning step you can extend / file system
HTH
tienna
HP is simple
Shameer.V.A
Respected Contributor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

Hi Joe,

It is possible. You can use the un-official procedure for extending root/swap in your case .. I'm attaching a document for the same. It's having official (through Ignite-Ux) & Un-Official ( Through Manual Copy of vg00).

Hope this will help you..

Shameer
.... See invisible, feel intangible and achieve impossible as everything is possible ....
Mohd Rasidi Che Mat
Frequent Advisor

Re: Need to extend /dev/vg00/lvol3 "/" mount point

this is what i did.
assumption:
primary disk - /dev/dsk/c2t1d0
secondary disk - /dev/dsk/c2t0d0
lvol1 - lvol6

unmirror lvol4-lvol6 from primary disk (to provide contiguous free space for lvol3)
#lvreduce -m 0 /dev/vg00/lvol4 /dev/dsk/c2t1d0
#lvreduce -m 0 /dev/vg00/lvol5 /dev/dsk/c2t1d0
#lvreduce -m 0 /dev/vg00/lvol6 /dev/dsk/c2t1d0

unmirror lvol3 from secondary disk (if not done lvol3 extension will fail because contiguous space is not freed yet on secondary disk)
#lvreduce -m 0 /dev/vg00/lvol3 /dev/dsk/c2t0d0

verify lvol4-lvol5 in /dev/dsk/c2t0d0
#lvdisplay -v /dev/vg00/lvol4
#lvdisplay -v /dev/vg00/lvol5
#lvdisplay -v /dev/vg00/lvol6

verify lvol3 in /dev/dsk/c2t1d0
#lvdisplay -v /dev/vg00/lvol3

increase lvol3
#lvextend -L 1024 /dev/vg00/lvol3
#fsadm -F vxfs -b 1024m /

mirror back the lvol4-lvol6 on primary disk
#lvextend –m 1 /dev/vg00/lvol4 /dev/dsk/c2t1d0
#lvextend –m 1 /dev/vg00/lvol5 /dev/dsk/c2t1d0
#lvextend –m 1 /dev/vg00/lvol6 /dev/dsk/c2t1d0

 

unmirror lvol4-lvol6 from secondary disk (to provide contiguous free space for lvol3)
#lvreduce -m 0 /dev/vg00/lvol4 /dev/dsk/c2t0d0
#lvreduce -m 0 /dev/vg00/lvol5 /dev/dsk/c2t0d0
#lvreduce -m 0 /dev/vg00/lvol6 /dev/dsk/c2t0d0

FIRST, mirror vol3 to secondary disk then followed by others
#lvextend -m 1 /dev/vg00/lvol3 /dev/dsk/c2t0d0
#lvextend -m 1 /dev/vg00/lvol4 /dev/dsk/c2t0d0
#lvextend -m 1 /dev/vg00/lvol5 /dev/dsk/c2t0d0
#lvextend -m 1 /dev/vg00/lvol6 /dev/dsk/c2t0d0