System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

New HP-UX 11iv3 build on bl870c i4 blade with 256 GB memory shows high system memory usage.

SOLVED
Go to solution
Rich_Consoli
Occasional Visitor

New HP-UX 11iv3 build on bl870c i4 blade with 256 GB memory shows high system memory usage.

Hi,

 

I've just loaded 11.31 on a new bl870c i4 with 256 GB of memory. It's patched up to Sept. 2013 quality pack. There are no applications installed on the server yet, although it will soon host Oracle 11.

 

The system is using 94% of physical memory while virtually doing nothing. I'm very concerned that when a database is loaded on the server, they'll be no memory left for applications and the system will start swapping (paging) and causing performance issues.

 

I've tried many variations of kernel tunable configurations including using only the defaults, tuning to the SAP recommended specs, lowering filecache_max & min way below the 5% and 3% defaults.

All these tunable changes only allowed me to get from 96% down to 94%.

 

Is anyone aware of any known issues either with the software or the new i4 blades that could be causing this high memory consumption?

 

I've attached gobs of output from glance, top, swapinfo, kcusage and kctune if anyone would care to peruse.

 

Any suggestions in how to get to the bottom of this would be appreciated.

 

Thanks,

Rich

6 REPLIES
Dave Olker
HPE Pro

Re: New HP-UX 11iv3 build on bl870c i4 blade with 256 GB memory shows high system memory usage.

Are you certain that Integrity VM & vPars is not enabled?  Try issuing the command:

 

/opt/hpvm/bin/hpvmstatus

 

And see what output you get.

 

Dave

Rich_Consoli
Occasional Visitor

Re: New HP-UX 11iv3 build on bl870c i4 blade with 256 GB memory shows high system memory usage.

...actually I didn't think of looking for virtuals, but I would hope that something using up all the memory would show up in one of those outputs.

 

# hpvmstatus
hpvmstatus: No vPars or VMs currently configured.
#

Thanks for the quick reply and suggestion.

Dave Olker
HPE Pro
Solution

Re: New HP-UX 11iv3 build on bl870c i4 blade with 256 GB memory shows high system memory usage.

Yup, that's the reason. Your system is configured as a VSP, which by default consumes 92% of all available memory whether any VM or vPar guests are running or not. Expected behavior.
Rich_Consoli
Occasional Visitor

Re: New HP-UX 11iv3 build on bl870c i4 blade with 256 GB memory shows high system memory usage.

I set HPVM_ENABLE=0 and rebooted and voila!  memory utilization is now at 11%.

At first I wondered why it was presumed that we'd be running this server as a VM host, but then again, why shouldn't that be presumed if the software is installed on the server.

Thanks for your help!

BTW, isn't there supposed to be a Kudos icon under your name?  I don't see it.

 

Rich

Rich_Consoli
Occasional Visitor

Re: New HP-UX 11iv3 build on bl870c i4 blade with 256 GB memory shows high system memory usage.

found the kudos when i returned. Thanks!
Dave Olker
HPE Pro

Re: New HP-UX 11iv3 build on bl870c i4 blade with 256 GB memory shows high system memory usage.

There is no presumption that every server will be a VSP.  However, if the Integrity VM & vPars product BB068AA is installed then it is enabled by default.  As far as I know this product is normally not installed in a default DCOE installation.  Not sure about VSOE installation.

 

Dave