cancel
Showing results for 
Search instead for 
Did you mean: 

No Java 5 on Tru64

SOLVED
Go to solution
Victor Semaska_3
Esteemed Contributor

No Java 5 on Tru64

Greetings,

We have a product whose new version requires Java V1.5.0_08. The current version supported by HP is 1.4.2-8. I saw on some vendor's site state: HP are not providing a Java 5 implementation for Tru64 Platform.

Is this true? If so, is there another way of getting Java 5 for Tru64?

Thanks,
Vic
There are 10 kinds of people, one that understands binary and one that doesn't.
4 REPLIES
Rick Retterer
Respected Contributor
Solution

Re: No Java 5 on Tru64

Vic,
Unfortunately, Java 1.4.2 is the last major version of Java that will be produced on the Tru64 Unix platform.

There may be a couple of patch updates to 1.4.2-* to trickle out of Java engineering, but 1.4.2 is the last version of Java on the Tru64 Unix Platform.

As far as I know, there is no other vendors offering Java 5 for Tru64 Unix.

Java 5, is available on other platforms such as Linux and HP-UX and other Unix platforms, and OpenVMS has Java 5 as well.

Unless someone else knows of another avenue to get Java 5, thats all I'm able to provide to you on the subject.

Cheers,
Rick Retterer

- Rick Retterer



Pieter 't Hart
Honored Contributor

Re: No Java 5 on Tru64

>>> We have a product whose new version requires Java V1.5.0_08 <<<

Is the product itself supported on Tru64???
then the vendor should know how to get a applicable Java version.
Rick Retterer
Respected Contributor

Re: No Java 5 on Tru64

Vic,
More information on the subject:

The decision to make 1.4.2.xx the terminal release is based on the promise of providing the most stable operating system ecosystem for Tru64 UNIX customers through the EOSL of Tru64 UNIX.

Introduction of a major new version of JAVA could be disruptive, to the targed EOSL of Tru64 UNIX.

Customers absolutely needing the enhanced functionality provided with JAVA V5.0 should consider migrating to HP-UX 11i which will support the latest versions of JAVA.

Several of these requests were traced back to Oracle development plans requiring JAVA V5.0 for an upcoming release. HP has worked with Oracle on the versions of their product suite that would be the â terminalâ or last version to be supported on Tru64 UNIX and concluded that there would not be a requirement for supporting JAVA V5.0.

A limited number of additional requests were made, but in most cases features provided in the JAVA V5.0 release were not mandatory to satisfy the customer and/or ISV requirements.

Rick
- Rick Retterer



Hein van den Heuvel
Honored Contributor

Re: No Java 5 on Tru64

>> Customers absolutely needing the enhanced functionality provided with JAVA V5.0 should consider migrating to HP-UX 11i

Or migrate to OpenVMS or a SUN box or AIX or anywhere else.

:-(

Hein.