System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

No more processes left in this runlevel

SOLVED
Go to solution
Chapaya
Frequent Advisor

No more processes left in this runlevel


I have a problem :

"Enter runlevel: 3
INIT:No more processes left in this runlevel "

Also , i i can take linux to single user ?

bye.
8 REPLIES
Vitaly Karasik_1
Honored Contributor
Solution

Re: No more processes left in this runlevel

Eran, for taking linux into single user level, just add

single

at the end of grub kernel line.
skt_skt
Honored Contributor

Re: No more processes left in this runlevel


1. Intervene at the boot prompt by selecting the required kernel version and hit e; select the kernel line and add single to the end; then hit b to boot

2. Edit grub file before rebooting.
kernel /vmlinuz-2.4.21-40.ELsmp ro root=/dev/vg00/lvol1 hda=ide-scsi usb-handoff single.
Chapaya
Frequent Advisor

Re: No more processes left in this runlevel


system in single user but i still get :

INIT: no more processes left in this runlevel
Vitaly Karasik_1
Honored Contributor

Re: No more processes left in this runlevel

but do you have shell prompt?

if no, I suggest to boot from some rescue CD (1st install CD, for example), mount and examine your system.

is it fresh installation? or you got this problem after upgrade?
Chapaya
Frequent Advisor

Re: No more processes left in this runlevel

i have ptompt but there are missing files under /etc .
There were some electricity problems ...
also fsck did not fix it .
Vitaly Karasik_1
Honored Contributor

Re: No more processes left in this runlevel



I see a few ways to fix this:
1) restore /etc from backup

2) copy /etc from another linux box and fix appropriate files (/etc/hosts, /etc/sysconfig/network, /etc/sysconfig/network-scripts/ifcfg-* and so on)
But probably you lost some files into other directories too...

3) reinstall

If your distribution is RPM-based, you can detect missed files by running

rpm -qaV

(after booting from a rescue disk)
skt_skt
Honored Contributor

Re: No more processes left in this runlevel

Go to rescue mode using the RHEL installation CD with the boot option:

linux rescue

if vg00 not getting mounted automaically.

2.Try to activate the volume groups by running the commands below:

lvmdiskscan
vgchange -ay

3.If vg00 is acitaved Further fsck test can be done using:

tune2fs -l /dev/vg00/lv01 | grep Block

Take note of the Block size.

e2fsck -b -n /dev/vg00/lv01


Also if you encounter any super block corruption then try
# mke2fs -n /dev/vgeb_gdh0_p/lvol10
mke2fs 1.32 (09-Nov-2002)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
131072 inodes, 262144 blocks
13107 blocks (5.00%) reserved for the super user
First data block=0
8 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376

# e2fsck -b 32768 /dev/vgeb_gdh0_p/lvol10
e2fsck 1.32 (09-Nov-2002)
/dev/vgeb_gdh0_p/lvol10 was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

/dev/vgeb_gdh0_p/lvol10: ***** FILE SYSTEM WAS MODIFIED *****
/dev/vgeb_gdh0_p/lvol10: 11/131072 files (0.0% non-contiguous), 12329/262144 blocks
Chapaya
Frequent Advisor

Re: No more processes left in this runlevel

i dont have lvm on this machine .

i will go to scrath installation . there are too many lost files on /etc which i see . may be on other fs also .

i seems electricity problems caused it .