System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to update HP-UX 11.23 to 11.31

SOLVED
Go to solution
Kaps_2
Regular Advisor

Not able to update HP-UX 11.23 to 11.31

Hello,

I have HP-UX 11.23 installed on rx2660, when I try to update it to 11.31 using update-ux I am getting the below error message.

NOTE: A reboot will be required to complete the installation of the selected
software.
* Running pre_update Check Scripts
* Running any scripts found in directory "/var/adm/sw/pre_update".
* Running "/var/adm/sw/pre_update/DOWNDATE_CHECK.002".
ERROR: You are attempting to update from your release of HP-UX to a version
of HP-UX that was released earlier in time. This is not supported.
The update process has stopped without making any changes to your
system. Please see the 'Supported Update Paths' section of the HP-UX
11i v2 Installation and Update Guide for more information.
ERROR: The script "/var/adm/sw/pre_update/DOWNDATE_CHECK.002" returned a
value of "1" (ERROR)
* Analysis Summary
- Reboot needed: Yes
- Kernel build needed: Yes
- Install: 43 bundles 366 filesets
- Update: 30 bundles 816 filesets
* Analyzing Software To Be Installed failed with 2 errors.

======= 05/20/09 19:33:32 IST END Operating Environment Update failed with 2
errors and 1 warning. (user=root) (jobid=000001)

ERROR: SWM terminated with errors without rebooting the system. See
/var/opt/swm/swm.log for details.
NOTE: One or more errors encountered. Take appropriate corrective action
and re-run update-ux to complete the update.

Please let me know what issue is cause this issue.

Thanks,
Kaps
4 REPLIES
Fabian Briseño
Esteemed Contributor

Re: Not able to update HP-UX 11.23 to 11.31

Hello Kaps.
What does /var/opt/swm/swm.log say ?.



Knowledge is power.
Kaps_2
Regular Advisor

Re: Not able to update HP-UX 11.23 to 11.31

NOTE: A reboot will be required to complete the installation of the selected
software.
* Running pre_update Check Scripts
* Running any scripts found in directory "/var/adm/sw/pre_update".
* Running "/var/adm/sw/pre_update/update_ok.001".
* The script "/var/adm/sw/pre_update/update_ok.001" returned a value of
"0" (SUCCESS).
* Running "/var/adm/sw/pre_update/DOWNDATE_CHECK.002".
ERROR: You are attempting to update from your release of HP-UX to a version
of HP-UX that was released earlier in time. This is not supported.
The update process has stopped without making any changes to your
system. Please see the 'Supported Update Paths' section of the HP-UX
11i v2 Installation and Update Guide for more information.
ERROR: The script "/var/adm/sw/pre_update/DOWNDATE_CHECK.002" returned a
value of "1" (ERROR)
* Running "/var/adm/sw/pre_update/DOWNDATE_CHECK.002". failed with 2
errors.
* Running "/var/adm/sw/pre_update/HPSIM.100".
* The script "/var/adm/sw/pre_update/HPSIM.100" returned a value of "0"
(SUCCESS).
* Running "/var/adm/sw/pre_update/INETSVCS.100".
* The script "/var/adm/sw/pre_update/INETSVCS.100" returned a value of
"0" (SUCCESS).
* Running "/var/adm/sw/pre_update/NISPLUS.100".
* The script "/var/adm/sw/pre_update/NISPLUS.100" returned a value of
"0" (SUCCESS).
* Running "/var/adm/sw/pre_update/NsaHttp.100".
* The script "/var/adm/sw/pre_update/NsaHttp.100" returned a value of
"0" (SUCCESS).
* Running "/var/adm/sw/pre_update/RNG-DKRN.100".
* The script "/var/adm/sw/pre_update/RNG-DKRN.100" returned a value of
"0" (SUCCESS).
* Running "/var/adm/sw/pre_update/VXVM-VXFS.100".
* The script "/var/adm/sw/pre_update/VXVM-VXFS.100" returned a value of
"0" (SUCCESS).
* Running "/var/adm/sw/pre_update/VirtualPartition.100".
* The script "/var/adm/sw/pre_update/VirtualPartition.100" returned a
value of "0" (SUCCESS).
* Running any scripts found in directory "/var/adm/sw/pre_update".
failed with 2 errors.
* Analysis Summary
- Reboot needed: Yes
- Kernel build needed: Yes
- Install: 43 bundles 366 filesets
- Update: 30 bundles 816 filesets
* Running pre_update Check Scripts failed with 2 errors.
* Analyzing Software To Be Installed failed with 2 errors.
* Removing Temporary Update Tools
* OE update tools to be removed:
- SW-GETTOOLS
- SWMTRANS
- Update-UX.SD-CMDS
- Update-UX.SD-AGENT
- Update-UX.UUX2-OS-LIBS
- Update-UX.SD-FRE-I-MSG
- Update-UX.SD-GER-I-MSG
- Update-UX.SD-JPN-E-MSG
- Update-UX.SD-JPN-S-MSG
- Update-UX.SD-KOR-E-MSG
- Update-UX.SD-TCH-B-MSG
- Update-UX.SD-TCH-H-MSG

======= 05/20/09 20:13:38 IST END Operating Environment Update failed with 2
errors and 1 warning. (user=root) (jobid=000002)
Rita C Workman
Honored Contributor
Solution

Re: Not able to update HP-UX 11.23 to 11.31

Check the dates on the DVD your using to upgrade from.

To give an example:
If your 11.23 was created with say June 2008 DVD's and your trying to upgrade to 11.31 with March 2008 DVD's - it won't work.

You must ensure that the newer version (11.31) DVD's are not from a revision date earlier than what the 11.23 was created with.

Rgrds,
Rita
Kaps_2
Regular Advisor

Re: Not able to update HP-UX 11.23 to 11.31

Thanks Rita, looks like I have the same issue