cancel
Showing results for 
Search instead for 
Did you mean: 

OKI Printer setup on Tru64

Vikas_15
Advisor

OKI Printer setup on Tru64

I have configured a print queue for "OKI Microline 8480SU-R" printer. The problem is that I am able to print ENGLISH characters but when any JAPANESE characters are there in the file, it prints that as JUNK characters. Earlier this printer was setup with the two files attached herewith. I dont have such file for Tru64. Can anyone help or suggest an alternate wayout for the same?

Best regards,
Vikas
18 REPLIES
Ralf Puchner
Honored Contributor

Re: OKI Printer setup on Tru64

it look like a print filter....

First it is important how the printer is connected (this will decide if a printfilter will be use or not) and second it is important what kind of file from what application or machine will be printed (this decides if the job must be filtered or not).

So why not giving some details? there is also a good documentation out there called "documentation library" delivered with your OS Cd-Rom containing the description of a printing system called "advanced printing"....
Help() { FirstReadManual(urgently); Go_to_it;; }
Michael Schulte zur Sur
Honored Contributor

Re: OKI Printer setup on Tru64

Hi,

please post the /etc/printcap entry for that printer.

thanks,

Michael
Vikas_15
Advisor

Re: OKI Printer setup on Tru64

I am using following entries in printcap file:

tyo017m0:\
:lf=/usr/spool/lpd/errors/tyo017m0.err:\
:sd=/usr/spool/lpd/tyo017m0:\
:rm=tyo017m0.tyo.pacific.testdomain.com:\
:rp=raw1:\
:if=/usr/lbin/pcfof +Cescp_a4_12cpi.pcf -Opcode=escp:\
:of=/usr/lbin/pcfof +Cescp_a4_12cpi.pcf -Opcode=escp:\
:mx=0:\
:pl=63:\
:pw=95:\
:xf=/usr/lbin/xf:\
:ya="plocale=ja_JP.eucJP":\
:lp=:ct=remote:sh:mx#0:

and locale values are as follows:
/users/mnin_tst locale
LANG=ja_JP.SJIS
LC_COLLATE="ja_JP.SJIS"
LC_CTYPE="ja_JP.SJIS"
LC_MONETARY="ja_JP.SJIS"
LC_NUMERIC="ja_JP.SJIS"
LC_TIME="ja_JP.SJIS"
LC_MESSAGES="ja_JP.SJIS"
LC_ALL=

I am able to get prints in English but as and when any japanese characters are there in the file, these are printed as junk.
Please advice.
Ralf Puchner
Honored Contributor

Re: OKI Printer setup on Tru64

ct=remote, lp=, rm=raw1
=> lpd printing doesn't support filtering, use tcp/telnetfiltering instead
Help() { FirstReadManual(urgently); Go_to_it;; }
Vikas_15
Advisor

Re: OKI Printer setup on Tru64

How to enable tcp/telnet filtering?
Michael Schulte zur Sur
Honored Contributor

Re: OKI Printer setup on Tru64

Hi,

sample entry
ham060061m1:\
:lp=@ham060061/lpt1:\
:of=/usr/lbin/myof:\
:sd=/usr/spool/ham060061m1:\
:sh:

lpt1 is a symbol for the port ranging here from 9100 up and is added to /etc/services

greetings,

Michael



Ralf Puchner
Honored Contributor

Re: OKI Printer setup on Tru64

but be sure your filter work with japanese characters, pipe a printfile through the filter and check. If it works correct your printcap entry.

Btw. tcp printing setup can be simple configured by using lprsetup (supported way, editing printcap manually is not supported), please read also the documentation prior posting!
Help() { FirstReadManual(urgently); Go_to_it;; }
Vikas_15
Advisor

Re: OKI Printer setup on Tru64

1. I like to pointout here that this printer is a remote printer.

2. How to check whether a filter is working fine for my printer or suitable for my requirements.
Ralf Puchner
Honored Contributor

Re: OKI Printer setup on Tru64

1. remote printing via lpd doesn't support filtering. This is a fact so changing the printing method is required to get a working filtering. Goodbye "remote" welcome "tcp" or "telnet" printing...

2. you don't know how to pipe a document through a filter? Maybe time to spent some time to study the basics of unix. A simple cat with pipe through the filter should do the job, after that operation print the converted document and see what is printed out. If it is ok use lprsetup to configure the printcap if not it is time to play around with other compatible pcl or postscript filters which can be found at /usr/lbin/.

Here is a link to the documentation which is also available on your documentation cd-rom delivered with the OS:

http://nf.apac.edu.au/facilities/sc/compaq_mirror/HTML/SUPPDOCS/JAPANDOC/JAPANCH8.HTM

it seems pcl is not supported with japanese characters, only plain text and postscript printfilters supports this features....
Help() { FirstReadManual(urgently); Go_to_it;; }
Vikas_15
Advisor

Re: OKI Printer setup on Tru64

Hello,

Now I have configured my print queue for tcp/telnet filtering as below:
(extracts of /etc/printcap)

------------/etc/printcap----------------------------------------
#Firnin OKI printer (28 Jun 04) . (:tyo017m0:)
tyo017m0:\
:ct=tcp:\
:lp=@tyo017m0/raw1:\
:lf=/usr/spool/lpd/errors/tyo017m0.err:\
:sd=/usr/spool/lpd/tyo017m0:\
:if=/usr/lbin/pcfof +Cescp_a4_12cpi.pcf -Opcode=escp:\
:of=/usr/lbin/pcfof +Cescp_a4_12cpi.pcf -Opcode=escp:\
:mx=0:\
:pl=63:\
:pw=95:\
:xf=/usr/lbin/xf:\
:ya="flocale=ja_JP.SJIS
plocale=ja_JP.SJIS":\
:sh:mx#0:

-----------------------------/etc/services-----------------------------------------

raw1 9120/tcp #Port for OKI Dotmatrix printer
-----------------------------------------------------------------------------------------
sin1002:/ # lpc status tyo017m0
tyo017m0:
printer is on device '/dev/lp' speed -1
queuing is enabled
printing is enabled
no entries
no daemon present


I tried and tested filter also (ESCP), filter is working fine. But now I am not able to get any printouts. My prints are getting stucked in spooling. Can anyone suggest that what is the mistake I have done in /etc/printcap file. I think that it is /etc/printcap file, that is causeing problems.

Please let me know the correction required in /etc/printcap file or /etc/services file which are mandatory for getting my printer in working condition. Please remember that this printer is connected in WAN connection at a remote location using a print server.

Best regards,
Vikas
Ralf Puchner
Honored Contributor

Re: OKI Printer setup on Tru64

"ya="flocale=ja_JP.SJIS
plocale=ja_JP.SJIS":\"

and "device is on /dev/lp" indicates a syntax problem. So why using an unsupported method, making mistakes during typing and asking for help? Use lprsetup as written several time before.....

Help() { FirstReadManual(urgently); Go_to_it;; }
Vikas_15
Advisor

Re: OKI Printer setup on Tru64

Only one doubt....

I am using "HP-Jetdirect 3263A" print server. It is having one port. I have configure telnet printing for this print server. What PORT NUMBER is EQUIVALENT to RAW1 port. Some sites says it should be 9100 and some are suggesting 9101. Can anyone confirm the same?

and if I add this port in /etc/services file .... syntax will be ...

raw1 9100/tcp #Port for raw1 for HP Jetdirect printer.

Many thanks,
Vikas
Michael Schulte zur Sur
Honored Contributor

Re: OKI Printer setup on Tru64

Hi,

try with 9100 if your doc does not say anything else. You will also have to do a inetd -h or kill -HUP on the inetd.

greetings,

Michael
Vikas_15
Advisor

Re: OKI Printer setup on Tru64

Hi,
I configured the printer using LPRSETUP utility and it started priniting. But the original problem of priniting JAPANESE is still remaining the same. I used ESCP filters with my print queue, but the outcome is that if a document containing ENGLISH and JAPANESE is given for printing, it prints ENGLISH but in place of Japanese characters, it prints JUNK characters. The /etc/printcap entry for this printer is as follows:

tyo017m8|lp4|tokyo2:\
:ct=tcp:\
:lf=/var/adm/errors/tyo017m8.err:\
:lp=@tyo017m0.tyo.pacific.firmenich.com/raw1:\
:if=/usr/lbin/pcfof +Cescp_a4_10cpi.pcf -Opcode=escp:\
:of=/usr/lbin/pcfof +Cescp_a4_10cpi.pcf -Opcode=escp:\
:mx#0:\
:of=/usr/lbin/lpf:\
:pl#66:\
:pw#80:\
:rm=@dpa:\
:rp=tyo017m8:\
:sd=/var/spool/lpd/tyo017m8:\
:xf=/usr/lbin/xf:\
:ya="plocale=ja_JP.SJIS":

locale settings are:

/users/mnin_mgr locale
LANG=ja_JP.SJIS
LC_COLLATE="ja_JP.SJIS"
LC_CTYPE="ja_JP.SJIS"
LC_MONETARY="ja_JP.SJIS"
LC_NUMERIC="ja_JP.SJIS"
LC_TIME="ja_JP.SJIS"
LC_MESSAGES="ja_JP.SJIS"
LC_ALL=

I studied in one Tru64 admin pdf (http://h30097.www3.hp.com/docs/base_doc/DOCUMENTATION/V51B_ACRO_DUX/ARH9FETE.PDF>> Page number 8-47 ) that filters may not work properly over different subnets. Is my problem related to this? Is there any other way to use this printer for Japanese prints?

At the sametime, I am having a Laser printer which is working fine in same setup and with text port settings. Moreover, that printer doesn't use any filter.

Can anyone suggest some wayout of my problem?

Many thanks in advance,
Vikas
Ralf Puchner
Honored Contributor

Re: OKI Printer setup on Tru64

as written before: pcl filtering with japanese may not work, please read the given pointers!

If piping of an sample text thru the filter does not work, so remote filtering does also not work...
Help() { FirstReadManual(urgently); Go_to_it;; }
Vikas_15
Advisor

Re: OKI Printer setup on Tru64

I used the following method to test the filter :

#cat test_japanese|=/usr/lbin/pcfof +Cescp_a4_10cpi.pcf -Opcode=escp

It give me output. It means filter is working. What can be other possibility?

Regards,
Vikas
Ralf Puchner
Honored Contributor

Re: OKI Printer setup on Tru64

no with your command you have piped the content through the filter and this will always work. But you must also print the generated output file on the printer to check if japanese characters will be really printed otherwise the test is absolut useless...

Btw. if it will not work maybe problem is the pcl filter, use postscript or text instead as written within the given link.
Help() { FirstReadManual(urgently); Go_to_it;; }
Vikas_15
Advisor

Re: OKI Printer setup on Tru64

OKI printer is not supporting Tru64 OS. However, OKI supports windows OS. I made use of Windows Print services for Unix , created a print queue in windows server, and then from Tru-64 server, the output of print queue in Tru64 box is directed to windows machine which is having Oki printer driver installed. Though it is a temporary solution, but working fine.

Thanks to all who responded and helped me to configure OKI printer for Tru64 server.