System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Os Upgrade from 11.11 to 11.23

 
emp001
Advisor

Os Upgrade from 11.11 to 11.23

I have the 11.11 OS is running now and looks like I have both 11.11-OE and 11.11-OE-ENT:

# swlist | grep -i oe
HPUX11i-OE B.11.11.0509 HP-UX 11i Operating Environment Component
HPUX11i-OE-Ent B.11.11.0406 HP-UX Enterprise Operating Environment Component
#


I am trying to do the upgrade to 11.23-OE
and having the error:
ERROR: Could not validate the viability of updating from B.11.11:HPUX11i-OE
HPUX11i-OE-Ent to HPUX11i-OE.
ERROR: Pre-Update script update_ok.001 failed.


Can you please help me.
Thank you.
Michael.
4 REPLIES
S_Logan
HPE Pro

Re: Os Upgrade from 11.11 to 11.23

Hi,

It is look like 2 Operating environment in the listing of Product index which is stopping the OS upgrade.

Please keep the Original OE and recreate the product index file. Then Proceed with the update ux.

Regards,
Surendar

I work for HPE

If you feel this solution was helpful please click the KUDOS! thumb below!
emp001
Advisor

Re: Os Upgrade from 11.11 to 11.23

So, my original OE is the first one = HPUX11i-OE-Ent, right ?

if so how I can recreate the product Index file,

On the 11.23 Source DVD I just have the 11.23-OE OS, so can I recreate the Index file so I will have the 11.11-OE nad then start the upgrade ?
S_Logan
HPE Pro

Re: Os Upgrade from 11.11 to 11.23

Hi Michael,

Iam not sure on that (which one is the Original OS).

We need to move the Orinal OS and INDEX file to /tmp folder and and recreate the Installed Products Database (/var/adm/sw/products/INDEX ) to resolve the issue.

I suggest you to Open a Call with HP response Centre to get the exact prcocedure for this.

Regards,
Surendar
I work for HPE

If you feel this solution was helpful please click the KUDOS! thumb below!
Dennis Handly
Acclaimed Contributor

Re: Os Upgrade from 11.11 to 11.23

>I am trying to do the upgrade to 11.23-OE

Instead of going upgrading from 11.11 to 11.23, you may want to cold install.