HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Out of range ' maxfiles_lim'

 
KCS_1
Respected Contributor

Out of range ' maxfiles_lim'

Hi,

when I was tring to change a kernel parameter maxfiles_lim (dynamic), got a message of the following.

----------------------------------------------

hp02[/]# sysdef | grep -i maxfiles
maxfiles 8192 - 30-2048 -
maxfiles_lim 1024 - 30-2048 -
hp02[/]# kmtune -s maxfiles_lim=8192
hp02[/]# kmtune |grep -i maxfiles_lim
maxfiles_lim 1024 Y 8192
hp02[/]# kmtune -u
kmtune: Unable to change maxfiles_lim. Out of range.


----------------------------------------------

It seems like no take effect after kmtune -u

How to figure it out??





Thanks
Easy going at all.
4 REPLIES
Adisuria Wangsadinata_1
Honored Contributor

Re: Out of range ' maxfiles_lim'

Hi Kim,

Check this url about maxfiles_lim :

http://docs.hp.com/en/939/KCParms/KCparam.MaxfileLim.html

See related parameters and check your system.

Hope this can help you.

Cheers,
AW
now working, next not working ... that's unix
Bejoy C Alias
Respected Contributor

Re: Out of range ' maxfiles_lim'

To be useful, the value assigned to maxfiles must be less than the value of maxfiles_lim. maxfiles_lim is useful only if it does not exceed the limits imposed by nfile and ninode.

Be Always Joy ......
vinod_25
Valued Contributor

Re: Out of range ' maxfiles_lim'

hi kim

Although the /usr/conf/master.d/core-hpux file contains the following
lines:

*range maxfiles<=2048
*range maxfiles_lim<=2048

the kernel can still be compiled manually with values for maxfiles and
maxfiles_lim larger than 2048. As explained in unix document
UNX1010203, 60000 is the upper bound for these parameters in HP-UX 10.20 and
above.

When trying to set either maxfiles or maxfiles_lim to larger than
2048, for example 4000, in System Administration Manager (SAM) the following
error occurs:

The value specified for tunable parameter "maxfiles", "4000", evaluates
to "4000" which is more than the maximum allowed value of "2048". SAM did not
have this problem at HP-UX 10.20.

At HP-UX 11.0 SAM relies on the /usr/conf/master.d/* files to set the
upper and lower values for kernel parameters. At HP-UX 10.20 the
/usr/sam/lib/kc/params.tx file was used. As already discussed the
/usr/conf/master.d/core-hpux file contains the following lines:

*range maxfiles<=2048
*range maxfiles_lim<=2048

To allow SAM to support setting either maxfiles or maxfiles_lim
to larger than 2048, the above lines in the /usr/conf/master.d/core-hpux
file must be changed to:

*range maxfiles<=60000
*range maxfiles_lim<=60000

After making the change, SAM may still have stored the old values within the
/var/sam/boot.config file. The boot.config file can be move out
of the way to cause SAM to recognize the changes made to the core-hpux
file. After moving the boot.config file, restaring SAM should cause
this file to be rebuilt using the new values. /usr/sam/lbin/getkinfo -b
can also be used to recreate the boot.config file.

Similarly, if maxfiles or maxfiles_lim have been set manually to
values larger than 2048, the above steps can be used to prevent SAM from
erroring on the parameter's values when entering the Configurable
Parameters menu item within SAM. Without making the above changes, SAM
will typically reset the "Pending Value" for these parameters back to 2048
anytime SAM is used.

Hope this will solve the issue ...

Regards

Vinod K
Tuan Nguyen_2
Frequent Advisor

Re: Out of range ' maxfiles_lim'

maxfile_lim is depended on nfile (maxusers) also, not only on "master.d/core-hpux" , maxfile_lim is max can be nfile+10.

Regards
Tuan


**how to solve
Set the maxfiles and maxfiles_lim parameters to at least 4096. (The table below recommends 8000 and 8196, respectively. You must first edit the /usr/conf/master.d/core-hpux file, to allow the SAM utility to set values greater than 2048:
http://publib.boulder.ibm.com/infocenter/wpdoc/v6r0/index.jsp?topic=/com.ibm.wp.ent.doc/wpf/os_hpux.html

Set maxfiles_lim before maxfiles !
NB: maxfile_lim is depend on nfile (maxusers)

kalle:root:/usr/conf/master.d #cp -p core-hpux core-hpux.old
maxfiles_lim    MAXFILES_LIM        8192        0
maxfiles        MAXFILES            4096          0

kalle:root:/root #kmtune -u -s maxfiles_lim=6363 , without “-u” you will not get an error !!

kalle:root:/root #kmtune |grep nfile
nfile                    6353  -  (16*(NPROC+16+MAXUSERS)/10+32+2*(NPTY+NSTRPTY+NSTRTEL))
kalle:root:/root #kmtune |grep file
file_pad                    -  -  10
maxfiles                 8190  -  8190
maxfiles_lim             5499  Y  5499
nfile                    6353  -  (16*(NPROC+16+MAXUSERS)/10+32+2*(NPTY+NSTRPTY+NSTRTEL))
sendfile_max                0  -  0
kalle:root:/root #kmtune -u -s maxfiles_lim=6363   (must max be nfile +10)
The kernel's value of maxfiles_lim has been set to 6363 (0x18db).
kalle:root:/root #kmtune -u -s maxfiles_lim=6364
kmtune: Unable to change maxfiles_lim.  Out of range.
kalle:root:/root #kmtune |grep file
file_pad                    -  -  10
maxfiles                 8190  -  8190
maxfiles_lim             6363  Y  6363
nfile                    6353  -  (16*(NPROC+16+MAXUSERS)/10+32+2*(NPTY+NSTRPTY+NSTRTEL))