System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

PSP 8.15 and 8.20 on RHEL 5U3 gives error -2701

 
kheller2
Frequent Advisor

PSP 8.15 and 8.20 on RHEL 5U3 gives error -2701

When using the gui to install PSP on 5U3 64bit trying to do a graphic install gives me an error -2701. -nui and -silent work fine. I even attempted this on a box where I did an @everything ks and I still get the error.

Running in verbose mode it says there are 0 packages to install then it gives the error.


The current log file name is now /var/log/hppldu.log
Now checking bundle ./bp000458.xml for support of this version of Linux.
Installed OS Version is Red Hat Enterprise Linux 5
A supported version of Red Hat Enterprise Linux was found
Please wait while the HP ProLiant Deployment Utility shuts down...
The Linux Deployment Utility has determined that there are 0 items to install.
The number of PCI Device records found was 42
The number of prerequisites found was 7
The number of PreConfiguration records found was 2
Component does have prerequisites.
Component does not have postrequisites.
Component does require pre-configuration.
Component does not require post-configuration.
Unaccounted for error -2701 occurred.

There is nothing in the logs. I can't be the only person experiencing this. I saw that someone was having problems with 8.11 and was told to install some X packages. Well, I have them installed and still get this error.
6 REPLIES
kheller2
Frequent Advisor

Re: PSP 8.15 and 8.20 on RHEL 5U3 gives error -2701

This will work under an real X session, but not using vncserver.
Tim Towers
Occasional Advisor

Re: PSP 8.15 and 8.20 on RHEL 5U3 gives error -2701

I am also receiving this error.
My RedHat servers are installed using the base packages and the ones listed in the PSP documentation. This means that graphical applications use the X server on my workstation rather than having a full graphical environment on the server.

The error is produced when hppldu runs.

+ ./hppldu
****************************************************************
HP ProLiant Deployment Utility for Linux
Copyright 2003-2009 Hewlett-Packard Development Company, L.P.
****************************************************************
Please wait while the HP ProLiant Deployment Utility shuts down...
Unaccounted for error -2701 occurred.
++ expr 252
kheller2
Frequent Advisor

Re: PSP 8.15 and 8.20 on RHEL 5U3 gives error -2701

If you are running an X server somewhere else, you can get this to install by setting the DISPLAY variable to that machine. (Works fine under Mac OS).

You can also do the -nui or -silent flags.
Tim Towers
Occasional Advisor

Re: PSP 8.15 and 8.20 on RHEL 5U3 gives error -2701

To confirm - my DISPLAY variable is set correctly since I can run graphical applications remotely such as firefox and the update application from the HP firmware CD.

I have not yet found a RHEL5.3 system where the psp-8.20 software will install graphically.
kheller2
Frequent Advisor

Re: PSP 8.15 and 8.20 on RHEL 5U3 gives error -2701

Here is what I'm using in my KS, this is for x8664 on AMD:

# ---- Packages ----
%packages --resolvedeps
@ Base
@ X Window System
@ FTP Server
@ Development Tools
@ Development Libraries
@ Legacy Software Development
@ System Tools
control-center
screen
libcap
ntp
nmap
vnc-server
openldap-servers
openldap-clients
vim-enhanced
sysstat
lynx
rusers
rusers-server
sendmail-cf
sendmail-doc
ncompress
# kexec-tools is needed for new kdump (diskdump replacement)
kexec-tools
# Tix is something HP said we needed for the agents in some crazy ticket they wrote to me.
tix

Later in post:
rpm -ivh http://ksserver.blah.com:/RH53/Depot/glib-1.2.10-20.el5.i386.rpm
(Note that GLIB is the 386 version and it will be in a different place, I just make a universal depot

Then this:

cd /root
curl http://ksserver.blah.com/HP/psp-8.20.rhel5.x86_64.en.tar.gz | tar -zxf -
cd /root/compaq/csp/linux
rm -f hp-lpfc-*
rm -f hp-OpenIPMI*
rm -f hp_qla2x00*

Note that I'm having problems keeping RH53 up and running on a 585G5 and I think it might be related to the PSP at the moment. I can't get kernel dumps as kexec is having problems with bonded interfaces. fun stuff.

kheller2
Frequent Advisor

Re: PSP 8.15 and 8.20 on RHEL 5U3 gives error -2701

Another thought, when I do this, I ssh -Y root@ to the server from an xterm. I haven't tried the X protocol over the WAN because of firewalls.