HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

PSP oddities with hpasm and hprsm

 
Don Vanco - Linux Ninja
Regular Advisor

PSP oddities with hpasm and hprsm

64-bit RHEL4U4 ES on AMD c-Class Blades (updates technically make it U5)

Trying to install the 7.8 PSP

The install states that hpasm and hprsm fail, offering the valuable information of "scriptlet failed, exit status 1" (thank you package authors)

At this point the system shows that the packages are not present, yet I can seemingly install them manually.

[root@cluster1 linux]# rpm -q hprsm

[root@cluster1 linux]# rpm -q hponcfg

[root@cluster1 linux]# rpm -ivh hprsm-7.8.0-75.rhel4.x86_64.rpm hponcfg-1.6.0-1.linux.rpm
Preparing... ########################################### [100%]
1:hprsm ########################################### [ 50%]
Please read the License Agreement for this software at

/opt/compaq/hprsm/hprsm.license

By not removing this package, you are accepting the terms
of the "License for HP Value Added Software".
Building custom cpqci driver
cpqci rebuilt, but failed to load.
No Insight Management devices available
(missing or disabled) on this system.
Please remove the hprsm package at your
earliest convenience (rpm -e hprsm).

==============================================================================
NOTE: New cma.conf entries were added to the top of /opt/compaq/cma.conf
==============================================================================
Starting HP Lights-Out Drivers and Agents (hprsm):

The hprsm RPM installation failed!
Installation failure may be due to incomplete or missing
build environment or to absent hardware (RILOE/RILOE II,
iLo/iLo 2). Please refer to the installation notes or to the
Linux Management HowTo available from http://www.hp.com/linux.
error: %post(hprsm-7.8.0-75.rhel4.x86_64) scriptlet failed, exit status 1
2:hponcfg ########################################### [100%]



Now it appears the files installed:
[root@cluster1 linux]# rpm -q hpasm hprsm
hpasm-7.8.0-88.rhel4
hprsm-7.8.0-75.rhel4


....and note the error message regarding the build of the cpqci driver (it builds but fails to load) And it says I have no iLO hardware????

If I examine the system I find this:
[root@cluster1 linux]# locate cpqci.ko
/opt/compaq/cpqci/driver/2.6.9-42.EL/cpqci.ko
/opt/compaq/cpqci/driver/2.6.9-42.ELsmp/cpqci.ko
/opt/compaq/cpqci/driver/2.6.9-42.ELlargesmp/cpqci.ko
/opt/compaq/cpqci/custom/.cpqci.ko.cmd
/opt/compaq/cpqci/custom/cpqci.ko

But note my running kernel (and it's the source that is present)
[root@cluster1 linux]# uname -r
2.6.9-55.0.2.ELsmp

The .42 kernel is the one that comes in U4 out of the box....


If I take a look at what it did to my PSP conf file I see:
# Following entries were added by HP Insight Management Agents at
# Tue Jul 10 15:37:10 EDT 2007
exclude cmhp cpqci cpqrid cpqriisd cmarackd cmasm2d


So I look at the PSP install log and see:
Parsing of XML file for cpq_cciss-2.6.16-5.rhel4.x86_64.rpm component
was SUCCESSFUL.
However, this RPM component DOES NOT SUPPORT the currently installed errata kernel.
Installation of this component will not be attempted.

Parsing of XML file for hpasm-7.8.0-88.rhel4.x86_64.rpm component
was SUCCESSFUL.

Parsing of XML file for hprsm-7.8.0-75.rhel4.x86_64.rpm component
was SUCCESSFUL.

Parsing of XML file for hpdiags-7.8.0-159.linux.i386.rpm component
was SUCCESSFUL.
Installation of this component is NOT SUPPORTED on this processor architecture.
Installation of this component will not be attempted.

??? I thought these PSPs supported EVERY platform and EVERY kernel in the 2.9.xx family???

I understand why it tries to install the x86_64 bits where possible, but why doesn't it install the 32-bit HP Diags as that's the only version available?


I have yet to reboot this system but have little expectation that it will come on-line without error.

I am totally baffled. Once again I am in front of a customer with a large Blade purchase and have to present a degree of alacrity, and once again HP PSP is kicking me in the nads for no apparent reason.

Any explanation welcome.... Should I attempt to remove the PSP components and try again ? (apparently this is not a very easy/clean task) I'm tempted to reinstall the server entirely. I need this to work cleanly, or I need to know that it's never going to for whatever reason....


Don
2 REPLIES
Steven E. Protter
Exalted Contributor

Re: PSP oddities with hpasm and hprsm

Shalom,

I've been seeing a lot of complaints on PSP 7.8.

If with updates you are update 5 you may be off the support matrix and may wish to remove the software.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Jeroen_D
Regular Advisor

Re: PSP oddities with hpasm and hprsm

We too are experiencing problems with PSP 7.80. This even includes servers on Windows/Linux getting unstable. We also noticed slower SAN access etc.

The NIC and HBA fiber drivers don't seem to be thoroughly tested.

We won't go to 7.80 on any server anymore. 7.70 does its work nicely.