System Administration
Showing results for 
Search instead for 
Did you mean: 

PXE not able to get image from server!

Regular Advisor

PXE not able to get image from server!

Hello Gurus,

Bootloader is not picking up the files for booting up-

1. The bios booted up.
2. DHCP Discovery, offer, request,ack succesfully done for this blade
3. The bootloader on this blade is not picking up the files for booting up

What could be the possibilities pxe is not picking the image from server?


PS: Attached syslog from server for DHCP packets
Jimmy Vance

Re: PXE not able to get image from server!

What is the error displayed on the console, and what server are you working with

No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Honored Contributor

Re: PXE not able to get image from server!

As you did not specify the name of your Linux distribution, I'll take a wild guess and assume you're talking about RedHat Enterprise Linux, maybe version 5.

In the attachment, the last line might be relevant:

Apr 15 12:48:53 CAPC2014 in.tftpd[28672]: tftp: client does not accept options

The PXE BIOS first gets an IP address and boot server name using DHCP, then uses the TFTP protocol to download the boot file from the boot server indicated in DHCP data.

The TFTP protocol has some optional features, which are not supported by all TFTP clients and servers. The log message seems to indicate the TFTP server tried to send some option data, but the client embedded in the PXE BIOS apparently did not understand it.

You might add the "-v" option to tftpd server arguments (in RHEL, the server_args line in /etc/xinetd.d/tftp) to get more verbose logging from the tftpd server process. Multiple "-v" options will give even higher verbosity.

"man in.tftpd" on RHEL5 says:
The -r option can be used to disable specific options; this may be necessary to work around bugs in specific TFTP client implementations.

For example, some TFTP clients have been found to request the "blksize" option, but crash with an error if they actually get the option accepted by the server.

If your PXE TFTP client has this bug, adding "-r blksize" to tftpd server arguments might help.

For information about other tftpd options, see "man in.tftpd".