System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Pam issue with ldapux - PAM: load_modules: can not open module /usr/lib/security/libpam_authz.1

 
Craig A. Sharp
Super Advisor

Pam issue with ldapux - PAM: load_modules: can not open module /usr/lib/security/libpam_authz.1

I am running HPUX 11.23. I have the following entries in /etc/pam.conf:

login account required /usr/lib/security/libpam_authz.1
OTHER account required /usr/lib/security/libpam_authz.1

Ldap is setup properly and I have verified with another server that the setup is exactly the same.

When I try to telnet to the server I get the following error in syslog.

Dec 14 09:53:04 ql2xxxxx PAM: load_modules: can not open module /usr/lib/security/libpam_authz.1

This module exists on the system. Here is the dir listing where the module is located:

-r-xr-xr-x 1 root sys 393184 Aug 29 2005 libpam_authz.1
lrwxr-xr-x 1 root sys 16 Sep 13 13:55 libpam_authz.so.1 -> ./libpam_authz.1

This is the same as on my 11.31 system except that the module on 11.31 is newer.

I am not sure what to do from this point.

Thanks
1 REPLY 1
Ivan Krastev
Honored Contributor

Re: Pam issue with ldapux - PAM: load_modules: can not open module /usr/lib/security/libpam_authz.1

Hello Craig,

Try to increase the debbuging on the system and PAM LDAP authentication - http://docs.hp.com/en/J4269-90071/ch04s16.html


regards,
ivan