System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Permission denied for NFS auto mount(exportfs works)

 
SOLVED
Go to solution
kenken_3
Regular Advisor

Permission denied for NFS auto mount(exportfs works)

HI,

I have one NFS server whose OS is 11.11 and one NFS client whose OS is 11.23. I enabled the automount for both servers, but I always get the error:Permission denied when I cd /mount.

however, when I disabled the automount and enable the exportfs on the nfs server and manually mount the remote system to the nfs client and it works well.

I wonder what is the possible reason for my automount failure.

here is the auto.direct from nfs client:

/mount -ro,soft,retry=2,proto=udp nfserver:/mount

I am using account root.

anyone can help?

Thanks
wang & wang
5 REPLIES
Matti_Kurkela
Honored Contributor
Solution

Re: Permission denied for NFS auto mount(exportfs works)

By default, the NFS server does not regard the root user of the NFS client as root, but as the "nobody" user. This is for security.

What are the directory permissions of the top-most mounted directory?

ll -d /mount

Automount requires exportfs on the NFS server just like a manual mount: there is no difference in the NFS server side. A mount is a mount.

MK
MK
Ganesan R
Honored Contributor

Re: Permission denied for NFS auto mount(exportfs works)

Hi Kenken,

I agree with Matti. For automount also you need to export the directory with proper permissions you need same like NFS mount.

The only difference for automount and NFS client is, automount will mount/umount on demand basis whereas NFS client will mount the directory permenantly.
Best wishes,

Ganesh.
Steven E. Protter
Exalted Contributor

Re: Permission denied for NFS auto mount(exportfs works)

Shalom,

Here is a sample(Linux) /etc/exports file.

#
/share/centos/5/iso *(rw)
/share/video *(rw,no_root_squash)


Note the no_root_squash remarks.

This is a way of suppressing the default behaviour of NFS which is to block root remote mounts.

To give help I would need to see the following:

/etc/exports configuration of the server.

/var/adm/syslog/syslog.log output on the server during the mount attempt.

Permissions on the server for the /mount/ folder. Very bad name by the way.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
kenken_3
Regular Advisor

Re: Permission denied for NFS auto mount(exportfs works)

you are right. When I enable automount, I removed the /etc/exports file from nfs server. Now I added it back and it is working now.

thanks.
wang & wang
kenken_3
Regular Advisor

Re: Permission denied for NFS auto mount(exportfs works)

it is closed
wang & wang