System Administration
Showing results for 
Search instead for 
Did you mean: 

Physical_ii_buffers kernel parameter setting

Occasional Visitor

Physical_ii_buffers kernel parameter setting

Help please

do you set this parameter in

B.11.23/  U 9000/800

 what doe the auto mean ?


We have 2 system set up the same  1 processor  4 gig memory each. san disk used.

on 1 system db job takes 46 minutes and on the other it takes 2h 28 min.

THe only difference I can see is in the kernel parameters

on fast system

set at physical_io_buffers 1280 Default Auto

on slow systemphysical_io_buffers 1024 Default Auto

sar shows high %wio on slow system


I have no idea of san specs. The systems are using different sans


would physical_io_buffers make much difference


Honored Contributor

Re: Physical_ii_buffers kernel parameter setting

>much difference? 




>what does the auto mean?


# kctune -v physical_io_buffers
Tunable             physical_io_buffers
Description         Number of buffers (512 bytes each) for physical I/O operations
Module              vm
Current Value       768 [Default]
Value at Next Boot  0 [Default]
Value at Last Boot  768
Default Value       768
Constraints         physical_io_buffers == 0 or physical_io_buffers >= 384
                    physical_io_buffers <= 65535
Can Change          Automatic Tuning Enabled


>The systems are using different sans

Here you go ... 

Occasional Visitor

Re: Physical_ii_buffers kernel parameter setting

There is a big difference


on fast system db update takes 46 mins slow system 2h .26 mins

on fast system db restore takes 2 hours on slow system it  takes 7H 32 mins - restore is from disk

 The databases are the same size  db configuration are the same . DB is informix

Honored Contributor

Re: Physical_ii_buffers kernel parameter setting

Still the same ... check the SAN ...



- Hardware is the same

- Software is the same

- Configuration is the same


- the SAN is the point to check.



Especially if you say the systems use different SANs and you don't know anything about it.


Changing the kernel parameter will not fix this.