System Administration

Re: Plz help me install qmail

 
SOLVED
Go to solution
Maaz
Valued Contributor

Plz help me install qmail

Plz help me install qmail
tar -xzvf qmail-1.03.tar.gz; cd qmail-1.03;
# make setup check

the complete error message is attached

Regards
Maaz
9 REPLIES 9
xyko_1
Esteemed Contributor
Solution

Re: Plz help me install qmail

Hi Maaz,

I guess you are having c compilation problems

./load auto-str substdio.a error.a str.a
substdio.a(substdo.o)(.text+0x43): In function `allwrite':
: undefined reference to `errno'

Verify if this version of qmail may be compiled with your version of c compiler (gcc).
To see the version of your C compiler run
rpm -qa | grep gcc

BTW, sorry to say it again, why don't you use Postfix my friend. It's the most easier MTA to install and setup that I know.

Regards,
xyko
Maaz
Valued Contributor

Re: Plz help me install qmail

I m very thankful to u Dear Xyko.

Ok i'll check and let u know about the version of c compiler.

I really highly appreciate ur sugestion, about using Postfix, but dear i m not the decision maker.. most of the time I m just responsible to implement the solutions.. choosing the best solution is not mine responsiblity.

Regards
Maaz

xyko_1
Esteemed Contributor

Re: Plz help me install qmail

Maaz my friend,
sometimes life is realy hard.

Don't worry "The force will be with you".

Go ahead and good luck.
Xyko
Steven E. Protter
Exalted Contributor

Re: Plz help me install qmail

Try updating the gcc compiler, see if that helps.

If that does not work, try a different version of qmail.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Maaz
Valued Contributor

Re: Plz help me install qmail

zillion of Thanks Dear Friend Xyko, for the support, and help.
Thanks SEP for the reply.

#rpm -qa |grep gcc

gcc-3.2.3-20
libgcc-3.2.3-20
gcc-c++-3.2.3-20

Now what u people think, should I try different version of qmail, or EITHER upgrade gcc ?

Thanks n Regards
Maaz
Gopi Sekar
Honored Contributor

Re: Plz help me install qmail

oh dear friend,

it seems like your error is already known to the world. check the below link, and look for the highlighted area containing text 'Some linux systems don't like the way qmail uses "errno":'

http://tomclegg.net/qmail-linux

Hope this helps,
Gopi
Never Never Never Giveup
Maaz
Valued Contributor

Re: Plz help me install qmail

Thanks Dear Friend Gopi Sekar for this very nice/perfect help ;).

Thanks Every1
Regards
Maaz
Paul Dejyothin
Occasional Contributor

Re: Plz help me install qmail

A very handy site for QMail installation with some bells & whistles is over at www.qmailrocks.org
Maaz
Valued Contributor

Re: Plz help me install qmail

thanx Dear Paul Dejyothin ;).

Regards
Maaz