System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Port 25 is not work, How to Enable?

SOLVED
Go to solution
Mousa55
Super Advisor

Port 25 is not work, How to Enable?

Hi,

i am try to connect to my server from the Dos by using telnet command and port 25 in this way
#telnet 10.8.1.62 25 but the error message is appeared
Connecting To 10.8.1.62...Could not open connection to the host, on port 25: Connect failed
how to check and enable the port 25.
and this port is working on another server without problem, and i applied the
#netstat -na |grep 25 command and this the output:

4ec52500 stream 0 0 0 4ecec280 0 0
4c2c2500 stream 0 0 0 4bcbf1c0 0 0 /tmp/.AgentSockets/A
4c378b80 dgram 0 0 4c25f040 4bcbfcc0 0 0 /opt/dcelocal/var/rpc/local/01396/c-3/7002
4c40b6c0 dgram 0 0 4c25f940 0 0 0 /var/spool/sockets/pwgr/client1403
4c43c040 dgram 0 0 4c25c7c0 0 0 0 /var/spool/sockets/pwgr/client1519
4c43c1c0 dgram 0 0 4c25cf40 0 0 0 /var/spool/pwgr/daemon
4ec4d580 dgram 0 0 625f6340 0 0 0 /var/spool/sockets/pwgr/client13360

how to solve this problem


Thanks & kind Regards

6 REPLIES
Ivan Krastev
Honored Contributor
Solution

Re: Port 25 is not work, How to Enable?

Start sendmail daemon:

/sbin/init.d/sendmail start

And to make it permanently - edit the /etc/rc.config.d/mailservs:

export SENDMAIL_SERVER=1



regards,
ivan
Analyst
Trusted Contributor

Re: Port 25 is not work, How to Enable?

Hi Nejad,

Check for the following files.
1. /etc/services--enable the telnet port, open the port from network side if you are trying to connect it over the network.
2. /var/adm/inetd.sec

Thanks,
Analyst.
Mousa55
Super Advisor

Re: Port 25 is not work, How to Enable?

Hi

i am applied this command to see what the port is enabled, but the port 25 is not on the list.

# netstat -an|grep LISTEN
tcp 0 0 *.1508 *.* LISTEN
tcp 0 0 *.3275 *.* LISTEN
tcp 0 0 *.2049 *.* LISTEN
tcp 0 0 *.7815 *.* LISTEN
tcp 0 0 *.543 *.* LISTEN
tcp 0 0 *.6112 *.* LISTEN
tcp 0 0 *.5555 *.* LISTEN
tcp 0 0 *.21 *.* LISTEN
tcp 0 0 *.901 *.* LISTEN
tcp 0 0 *.49156 *.* LISTEN
tcp 0 0 *.49158 *.* LISTEN
tcp 0 0 *.4045 *.* LISTEN
tcp 0 0 *.49157 *.* LISTEN
tcp 0 0 *.49152 *.* LISTEN
tcp 0 0 *.2148 *.* LISTEN
tcp 0 0 *.49200 *.* LISTEN
tcp 0 0 *.2121 *.* LISTEN
tcp 0 0 *.49406 *.* LISTEN
tcp 0 0 *.111 *.* LISTEN
tcp 0 0 *.22 *.* LISTEN
tcp 0 0 *.49415 *.* LISTEN
tcp 0 0 *.49414 *.* LISTEN
tcp 0 0 *.49277 *.* LISTEN
tcp 0 0 *.1712 *.* LISTEN
tcp 0 0 *.49155 *.* LISTEN
tcp 0 0 *.49154 *.* LISTEN
tcp 0 0 *.49153 *.* LISTEN
tcp 0 0 10.8.1.62.1521 *.* LISTEN
tcp 0 0 *.7161 *.* LISTEN
tcp 0 0 *.5989 *.* LISTEN
tcp 0 0 *.49404 *.* LISTEN
tcp 0 0 *.49344 *.* LISTEN
tcp 0 0 127.0.0.1.49164 *.* LISTEN
tcp 0 0 *.135 *.* LISTEN
tcp 0 0 *.49161 *.* LISTEN
tcp 0 0 *.6051 *.* LISTEN
tcp 0 0 *.49234 *.* LISTEN
tcp 0 0 *.23 *.* LISTEN
tcp 0 0 *.513 *.* LISTEN
tcp 0 0 *.514 *.* LISTEN
tcp 0 0 *.512 *.* LISTEN
tcp 0 0 *.49291 *.* LISTEN
tcp 0 0 *.49303 *.* LISTEN
tcp 0 0 *.52733 *.* LISTEN
tcp 0 0 *.113 *.* LISTEN
tcp 0 0 *.515 *.* LISTEN
tcp 0 0 *.13 *.* LISTEN
tcp 0 0 *.37 *.* LISTEN
tcp 0 0 *.2301 *.* LISTEN
tcp 0 0 *.769 *.* LISTEN
tcp 0 0 *.7 *.* LISTEN
tcp 0 0 *.9 *.* LISTEN
tcp 0 0 *.544 *.* LISTEN
tcp 0 0 *.19 *.* LISTEN
tcp 0 0 *.52738 *.* LISTEN
tcp 0 0 *.382 *.* LISTEN
Steven E. Protter
Exalted Contributor

Re: Port 25 is not work, How to Enable?

Shalom,

Perhaps start the sendmail daemon so some application is running on port 25

/sbin/init.d/sendmail start

For permanent auto start:
edit:
/etc/rc.config.d/mailsvr

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Analyst
Trusted Contributor

Re: Port 25 is not work, How to Enable?

Hi nejad,

In my earlier post I gave you wrong information, that was abt telnet instead of smtp port.

I Appologise for that,

SMTP uses port 25, ftp uses 21, telnet uses 23.

Thanks,
Analyst.
Mousa55
Super Advisor

Re: Port 25 is not work, How to Enable?

Hi all

thanks for all, to help me