System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Printer transfer - queues not working

Douglass A Anderson
Frequent Advisor

Printer transfer - queues not working

I have a system with printers and printers are working fine.
I migrated printers (like I have done in the past) using /usr/sam/lbin/lpmgr -S. but now none of the printers are working on the new system.
Is there a setting I need to change or a service I need to start.
The original system was 11.11i and the new systems was 11.00. I know why would anyone do this, but still. Any insight? The print outs go into the queue but they never leave (unless I cancel them. Syslog and lpd.log do not show anything. What else can I look at?
5 REPLIES
TTr
Honored Contributor

Re: Printer transfer - queues not working

> or a service I need to start.
Is lpsched running?

What do lpstat -o and lpstat -v show for the queues?

Check the permissions on the /etc/lp, var/lp and compare them the the old server (actually the newer 11i server).
Douglass A Anderson
Frequent Advisor

Re: Printer transfer - queues not working

Yes scheduler is running.
See attachment for other answers
TTr
Honored Contributor

Re: Printer transfer - queues not working

Check the permissions and ownership of all the subdirectories in /var/spool.

If you don't find anything do the following.

1. /sbin/init.d/lp stop
2. ps -ef | grep lp ( and kill any leftover lp processes)
3. cd /var/spool/lp
4. delete the FIFO, SCHEDLOCK, and any lock files.
5. cp /dev/null outputq
6. cp /dev/null log
7. /sbin/init.d/lp start

Ensure the lpsched is running and print a test file. Check the /var/spool/lp/log for any hints.
Douglass A Anderson
Frequent Advisor

Re: Printer transfer - queues not working

there were no FIFO or lock files, but the jobs are not leaving the queue.

NEW# more log
***** LP LOG: Nov 19 10:24 *****
crl_rep1_1-6246 root crl_rep1_1 Nov 19 10:25
Start: crl_rep1_1-6246 Fri Nov 19 10:25:22 EST 2010
Start: crl_rep1_1-6246 Fri Nov 19 10:25:42 EST 2010
NEW# lpstat -t | head
scheduler is running
no system default destination
device for alg_acct1: /dev/null
device for alg_acct2: /dev/null
device for alg_amada1: /dev/null
device for alg_dispatch1: /dev/null
device for alg_eng1: /dev/null
device for alg_hr1: /dev/null
device for alg_hr2: /dev/null
device for alg_ie1: /dev/null
NEW# lpstat -i -o | grep priority| sort
crl_rep1_1-6246 root priority 0 Nov 19 10:25 on crl_rep1_1
NEW# lpstat -i -o | grep priority| sort
crl_rep1_1-6246 root priority 0 Nov 19 10:25 on crl_rep1_1
Douglass A Anderson
Frequent Advisor

Re: Printer transfer - queues not working

I found the issue.

All printers were hard coded to /opt/hpnpl

solution

ln -s /opt/hpnp /opt/hpnpl
lpshut
lpsched