ProLiant PSP on Novell OES?

 
Richard Derby
New Member

ProLiant PSP on Novell OES?

How do I apply HP's Support Pack on an OES SP1 server?

- ProLiant DL360 G4p
- Novell Open Enterprise Server SP1
- Downloaded psp-7.40.sles9.linux.en.tar.gz (for SUSE Linux Enterprise Server 9 (x86)
- After decompressing the tar and running ./install740.sh, an error message says that the source code for the kernel is required but is not present and that the required compat-sles8-1.3-93 or later library is missing. HP's documentation confirms that NIC drivers must be compiled.

Can HP's SLES9 support pack be applied to OES SP1? Apparently there is no OES version of the support pack. Can I install the source code and the missing library and re-run the support pack?
2 REPLIES 2
Gopi Sekar
Honored Contributor

Re: ProLiant PSP on Novell OES?


yes, you can use SLES 9 support pack to OES SP1 server, we do the same with RDP.

Reasons for your error message is:
* You need to have kernel-source package installed on your system. Check the OES CDs for kernel-source package(the file name generally starts as kernel-source)
* Also you need to have compat-sles8 package installed on the OES box in order to get PSP 7.40 installed properly. This package is also available in the CD (package name is compat-sles8)

you can use yast2 (OES administration utility), to install above packages.

Hope this helps,
Gopi
Never Never Never Giveup
Jaroslav Matys
Respected Contributor

Re: ProLiant PSP on Novell OES?

You could also install directly packages, and then you don't need kernel sources nor compat-sles8. It works fine on SUSE professional 9.3. You need libelf for net-snmp-cmaX.

hpacucli-7.40-7.linux.rpm
hprsm-7.4.0-50.sles9.x86_64.rpm
hpadu-7.40-7.linux.rpm
hpsmh-2.1.2-127.linux.x86_64.rpm
hpasm-7.4.0-56.sles9.x86_64.rpm
net-snmp-cmaX-5.1-220.sles9.x86_64.rpm
cmanic-7.4.0-7.sles9.linux.rpm
hpdiags-7.4.0-11.linux.i386.rpm
cpqacuxe-7.40-8.linux.rpm
hponcfg-1.2.0-4.linux.rpm