cancel
Showing results for 
Search instead for 
Did you mean: 

Problem disabling xhost

Problem disabling xhost

For security reasons, I am attempting to disable xhost on my 11:23 system. I run the command:

# xhost -
access control enabled, only authorized clients can connect
xhost: must be on local machine to enable or disable access control.

All seems well, however, when I run the command xhost with no options is says the access control is disable:

# xhost
access control disabled, clients can connect from any host

What am i missing?

5 REPLIES
Steven E. Protter
Exalted Contributor

Re: Problem disabling xhost

Shalom,

Its disabled by default.

xhost +

That will disable security

You appear to be trying to enable something that is already enabled.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Problem disabling xhost

From what i understand the 'xhost' cmd will show the status, it ALWAYS shows Disabled whether the prior command is 'xhost -' or 'xhost +'
Dennis Handly
Acclaimed Contributor

Re: Problem disabling xhost

>What am I missing?

My xhost works on 11.11 and 11.23:
$ xhost
access control enabled, only authorized clients can connect
...

>xhost cmd will show the status

Yes:
nothing: If no command line arguments are given, a message indicating whether or not access control is currently enabled is printed, ...

>it ALWAYS shows Disabled whether the prior command is 'xhost -' or 'xhost +'

What about using "xhost name"?

Have you looked at ACCESS CONTROL under X(1)?

Re: Problem disabling xhost

PROBLEM RESOLVED - With going into details, mainly becasue I can't :-) The problem was caused by a secuirty setting, within my Exceed (Hummingbird) application.
dictum9
Super Advisor

Re: Problem disabling xhost

What was that setting in Exceed?

 

I am getting that exact same error message.