System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem of LUN Detection over rx2660

SOLVED
Go to solution
ASIFKHAN
Frequent Advisor

Problem of LUN Detection over rx2660

Hi Freinds & Seniors,

I am facing one problem and its description is as follows:

System Details:
EVA4400 â only FP1 ports were connected to SAN switch; FP2 are not connected

RX2660 â LUNs from EVA4400 were allocated to this server



Problem: When rebooting the server storage mount points were not mounting; /etc/fstab is ok. Syslog says cannot query physical volume cxtydz.

And also when I am running #ioscan -fun then it is not showing the SAN storage Disks(LUNS) device files ,and thus it compelled me to run

#ioscan -fn, to manually make it to detect LUNS.
Then #vgchange -a y vg'sname
#mount -ae

But if server is HALTED and then powered ON all external mount points were mounted.And i didn't need to run any commands loke ioscan -fn or vgchange -a y or mount .

Plz suggest me your solutions and here i am attaching zip file for assistance in diagnosis.


11 REPLIES
Analyst
Trusted Contributor

Re: Problem of LUN Detection over rx2660

Hi mohd,

1.Did the LUN have alternath path configured.
2.check for the FC Zoning to the LUN configured.
3.reboot once the machine.
go for #ioscan -fnC disk,
#insf -eH

4.reboot the machine again .check for the errors.
still face the problem,revert back with the errors.



ASIFKHAN
Frequent Advisor

Re: Problem of LUN Detection over rx2660

Hi Analyst,

It doesn't has any zoning but yes it has Alternate path configured, but all the path along with alternate path doesn't appear after reboot until & unless i run command ioscan -fn.

I will try your sugeested method of insf -eH and then will reply to you.But before to that if u have any thing then plz suggest me .

Thanks ...
Hasan Atasoy
Honored Contributor

Re: Problem of LUN Detection over rx2660

hi ,

what about AUTO_VG_ACTIVATION in /etc/lvmrc . if you dont have a cluster system it must be equal to 1

Hasan
Analyst
Trusted Contributor
Solution

Re: Problem of LUN Detection over rx2660

Hi mohd,

The Zoning I mentioned earlier is, to be done from Storage part.
From OS part we are making use of it as alternate link.
Please discuss with storage team to check all the path is working for a LUN ( Example - 2 or 3 path per LUN).

Thanks Hasan ,
To bring notice of that.
In case of clustered VG. The Non-rootvg to be activated automatically.
please check thatone too.


Thanks,
Analyst.
Johnson Punniyalingam
Honored Contributor

Re: Problem of LUN Detection over rx2660

Hi,

Do you have AUTO_VG_ACTIVATE=1 in '/sbin/lvmrc' or do you have this set to zero (0) where you must delare the volume groups you want activiated in '/etc/lvmrc' in its 'custom_vg_activation()' function?

Check for any errors in /etc/rc.log

I am guessing that the disks for this volume group are not visible by the server early in the boot process. Some process attaches them later on and by then it is too late.

Also do you have a serviceguard package set up in this server?

Thanks,
Johnson
Problems are common to all, but attitude makes the difference
ASIFKHAN
Frequent Advisor

Re: Problem of LUN Detection over rx2660

Hi Analyst/Hasan/Johnson,

Analyst: I have done zoning but still facing the same problem.

Hasan/Johnson:Yes ,its /etc/lvmrc has AUTO_VG_ACTIVATE= 1".

And 1 more thing that it doesn't have any cluster..

Thanks
Sagar Sirdesai
Trusted Contributor

Re: Problem of LUN Detection over rx2660

Let us know if you are using any multipath software.
john123
Trusted Contributor

Re: Problem of LUN Detection over rx2660

I suspect its some thing related to the firmware.. EVA and switch firmwares are up to date ?

John
ASIFKHAN
Frequent Advisor

Re: Problem of LUN Detection over rx2660

Hi Sagar,

Yes one such multipathing software is installed but would it has any role in this LUN detection problem??

Yes john,

We are also thinking of upgrading SAN switch firmware but EVA controller firmware is the latest one.

Thanks
Asif khan
Sagar Sirdesai
Trusted Contributor

Re: Problem of LUN Detection over rx2660

Hi

In some cases the vg activation is initaited
before the mulipath software or script runs while boot up.
Can you let me know th emultipath software name

Sagar
ASIFKHAN
Frequent Advisor

Re: Problem of LUN Detection over rx2660

Hi,

Although we are using the multipath software but it is not the issue.
becoz we just changed the FC card on host and done the zoning again.

Thanks
asif khan