System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem running Collect on Tru64 Unix

Bobcat_1
Advisor

Problem running Collect on Tru64 Unix

Hi,
Unable to execute the following Collect cmd ;

/usr/sbin/collect -S -n 30 -i 1 -Hd00:01 -f /usr/field/collectlog/collect.log

The error messages is ;

chmod or chown failed.: No such file or directory.

Any help please ?
Thanks
7 REPLIES
Blake Roberts
Frequent Advisor

Re: Problem running Collect on Tru64 Unix

I ran the collect command, and everything looks right as far as the syntax goes. With the "no such file or directory" error, verify that the /usr/field/collectlog directory is there.

Regards,
--Blake Roberts
Bobcat_1
Advisor

Re: Problem running Collect on Tru64 Unix

Thanks for the reply.

The mentioned directory ;(usr/field/collectlog) was already created before.

Initially, tried this syntax via script but failed with same error. Running it directly produces same error.
Running it on a different server also produces same error .

Thanks.

Victor Semaska
Frequent Advisor

Re: Problem running Collect on Tru64 Unix

Are you running collect from the root account?

If not, maybe there's a permissions problem in that directory path.

Vic
Bobcat_1
Advisor

Re: Problem running Collect on Tru64 Unix

Thanks for the reply.

All access is via root id.

More infor ;

# pwd
/usr
# ls -l |grep field
drwxr-xr-x 14 root system 8192 Apr 29 01:44

ls -l |grep collect
drwxr-xr-x 3 root system 8192 Apr 28 18:48 collect
drwxr-xr-x 2 root system 8192 Apr 29 01:44 collectlog

# cd /
# collect -S -n 30 -i 1 -Hd00:01 -f /usr/field/collectlog/collect.log
# chmod or chown failed.: No such file or directory

Thanks.
Bobcat_1
Advisor

Re: Problem running Collect on Tru64 Unix

Hi,
The issue has been resolved.
It is related to the Unix cdsl link. The destination dir/file must be created such as ;

mkdir /usr/var/cluster/members/memberX/adm/collect.dated

(substituting the appropriate member number for 'X' )

Another question ;

/etc/rc.config has the following enabled ;

COLLECT_AUTORUN="1"
COLLECT_COMPRESSION="1"
COLLECT_ARGS="-S -n 30 -i 200 -Hd00:01 -f /var/adm/collect.dated/"

After a restart, collect starts automatically.
However ,output of "ps -ef |grep collect" shows ;

/usr/sbin/collect -i60,120 -f /var/adm/collect.dated/collect -H d0:5,1w -W 1h -M 10,15.

Why is the syntax set in /etc/rc.config, is not followed but the default value is used instead ?

COLLECT_ARGS="-S -n 30 -i 200 -Hd00:01 -f /var/adm/collect.dated/"

Bobcat_1
Advisor

Re: Problem running Collect on Tru64 Unix

Hi again,
Managed to resolve my question.

Nevertheless, thanks for the help.
Regards.
Johan Brusche
Honored Contributor

Re: Problem running Collect on Tru64 Unix



COLLECT_DEFAULT_ARGS="-i60,120 -f /var/adm/collect.dated/collect -H d0:5,1w -W 1h -M 10,15"

Above is the default as found in /sbin/init.d/collect, if collect ran like that on your system, it would mean that "rcmgr get COLLECT_ARGS" resulted in an empty string.

Rgds,
Johan.


_JB_