System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem seeing disks on RP7420 and expanding existing disks

SOLVED
Go to solution
Debbie Beresford
Frequent Advisor

Problem seeing disks on RP7420 and expanding existing disks

I have an RP7420 with 2 cells.  I want to ignite both cells with a tape from an existing system.  I know it works because I was able to do so with the same tape and the system attached to an IBM FastT SAN. 

We are now trying to attach an IBM 1746 (I believe it is as DS3512) SAN and i am having problems.

 

I originally asked for 3 - 2TB disks as I believe the RP7420 has a size limit for disks.  I am able to see all disks when I do an ioscan.  when I go into SAM, I am only able to see one of the disks.  The network guys did some playing around and deleted one of the 2TB disks and added a 10GB and a 50 GB disk.  Now in ioscan I see 4 disks.  When I try to create a vg, I have 4 disks available; 10GB, 50GB and the universal Xport for those two disks.  If I try to do a vgcreate to one of the 2 TB disks, It takes about 40 minutes before it fails and tells me the disk is busy.

 

When I try to create a VG using SAM and one of the disks I can see, I get the message it failed doing a vgextend.

 

Does anyone have any ideas as to what I can look at?  I am being told by the network side there are no problems and everything is working fine.

 

I have attached a copy of ioscan, diskinfo and print screens from SAM.

5 REPLIES
Torsten.
Acclaimed Contributor

Re: Problem seeing disks on RP7420 and expanding existing disks

The first idea that came to my mind is to check the presentation mode of the LUN from the array. If this is not HP-UX but default, windows, linux or something else you will get some very strange results because of the wrong address mode.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Debbie Beresford
Frequent Advisor

Re: Problem seeing disks on RP7420 and expanding existing disks

That was checked and they do show HP-UX. 

Re: Problem seeing disks on RP7420 and expanding existing disks

Debbie,

 

You don't mention the HP-UX version here? Some (all?) disk arrays require a different presentation mode for HP-UX11iv3 (11.31)  compared to what they needed for HP-UX11iv1 (11.11) or 11iv2 (11.23).

 

Has this been checked to that level of detail?


HTH

Duncan
Solution

Re: Problem seeing disks on RP7420 and expanding existing disks

Actually now I look at it, you are using SAM which implies you are on 11iv1 or 11iv2, but not on 11iv3, which doesn't have SAM!

 

So I think this might be your problem... if I go to IBM's support matrix tool for their storage:

 

http://www-03.ibm.com/systems/support/storage/ssic/interoperability.wss

 

and filter on "DS3500" in the "Storage Version" search, "Hewlett Packard" in the "Host Platform" search and "HP 9000 Servers" on the "Server Model" search, I see that it appears the DS35xx has never supported 11iv1, and only supported 11iv2 on an old firmware rev (07.70.16). Since then it only supported 11iv3.

 

So that might be your issue - not supported...


HTH

Duncan
Debbie Beresford
Frequent Advisor

Re: Problem seeing disks on RP7420 and expanding existing disks

Thank you very much Duncan.  I do not know what firmware revision the SAN is running but as it is new, I would assume it is not one that is supported.  We are running HP-UX 11.23.  We did manage to add disks and volume groups from the command prompt but there were still questions about the way it needed to be done.  Not supported answers those questions.