System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem updating HBA firmware

MIchael O'Connor_5
Occasional Visitor

Problem updating HBA firmware

Hi all,
I'm trying to upgrade the HBA firmware on a number of servers with the following command....

./hbacmd download 10:00:00:00:c9:99:73:e6 /tmp/lpe1150_wf282a4.all

I've tried it on several machines and get the same error. I tried downloading the package again incase it was corrupted, but the same thing happens.

ERROR: <194>: Incompatible Image

Has anyone seen this before or know a way around it? I'm well and truly stumped.

thanks.
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: Problem updating HBA firmware

Shalom,

On the looks of it, it would appear you have downloaded the wrong software. I'd check the basic process that led you here.

It would however be helpful to know what Linux distro is being used, the HBA and server type, and details such as that. This information might enable people on the forum to check your work.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
John Guster
Trusted Contributor

Re: Problem updating HBA firmware

Most likely the firmware file downloaded is not for the type of hardware(HBA) you have. What is the model/vendor of the HBA you are using?
John Guster
Trusted Contributor

Re: Problem updating HBA firmware

maybe try lunch GUI to upgrade the firmware by execute /usr/sbin/hbanyware/ocmanager after downloaded the correct fimware file.
MIchael O'Connor_5
Occasional Visitor

Re: Problem updating HBA firmware

Thanks for the replies so far guys, here are some more details.

HBA Model

HP FC2142SR 4Gb PCI-e, SC, Fibre Channel Adapter

[ host2]# cat lpfc_drvr_version

Emulex LightPulse Fibre Channel SCSI driver 8.2.0.33.3p

OS

Red Hat Enterprise Linux Server release 5.3 (Tikanga)

All software downloaded from hereâ ¦

http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?prodNameId=1143949〈=en&cc=uk&prodTypeId=12169&prodSeriesId=1809835&taskId=135

for firmware I used the link at the bottom of the page.

Thanks
Michael
MIchael O'Connor_5
Occasional Visitor

Re: Problem updating HBA firmware

Some more info I installed the fibrechannel enablement kit, and then installed the drivers from the link below, I think this could be the root of my problems.



http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=uk&prodTypeId=12169&prodSeriesId=1809835&prodNameId=1143949&swEnvOID=4004&swLang=8&mode=2&taskId=135&swItem=co-61153-1


./INSTALL

===Installing Emulex Driver(s)===

Preparing... ########################################### [100%]

1:hp-lpfc ########################################### [100%]

Writing /etc/hp_lpfc.conf...OK

Copying libemsdm.so

Saving /lib/modules/2.6.18-128.el5/kernel/drivers/scsi/lpfc/lpfc.ko

Building lpfc.ko..

make -C /lib/modules/2.6.18-128.el5/build SUBDIRS=/opt/hp/hp-lpfc/lpfc CONFIG_SCSI_LPFC=m clean

make[1]: Entering directory `/usr/src/kernels/2.6.18-128.el5-x86_64'

make[1]: Leaving directory `/usr/src/kernels/2.6.18-128.el5-x86_64'

make -C /lib/modules/2.6.18-128.el5/build SUBDIRS=/opt/hp/hp-lpfc/lpfc CONFIG_SCSI_LPFC=m modules

make[1]: Entering directory `/usr/src/kernels/2.6.18-128.el5-x86_64'

CC [M] /opt/hp/hp-lpfc/lpfc/lpfc_mem.o

make[1]: Leaving directory `/usr/src/kernels/2.6.18-128.el5-x86_64'

Build of lpfc.ko did not succeed

The driver compilation failed!

Driver build did not succeed!

error: %post(hp-lpfc-8.2.0.22_p1-3.noarch) scriptlet failed, exit status 1

===Installing fibreutils===

Preparing... ########################################### [100%]

package fibreutils-3.1-2.x86_64 (which is newer than fibreutils-2.4-3.x86_64) is already installed

Creating new initrd - HP-initrd-2.6.18-128.el5.img

Installation Complete
MIchael O'Connor_5
Occasional Visitor

Re: Problem updating HBA firmware

I was being a massive numpty and trying to install the incorrect hp-lpfc driver.

This one worked in the end.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=uk&prodTypeId=12169&prodSeriesId=1809835&prodNameId=1143949&swEnvOID=4004&swLang=8&mode=2&taskId=135&swItem=co-55772-1


Thanks again for the replies.