cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with NIC settings

Atul Gautam
Valued Contributor

Problem with NIC settings

Hi All,

I've a Dell PowerEdge 2650 server having onboard PCI based Broadcom Tigon3 10/100/1000BaseT Ethernet Cards.

When I check out the NIC settings using the command "ethtool", it gives me the following output --

-----------------------------------------------
[root@cubot3 root]# ethtool eth1
Settings for eth1:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: g
Wake-on: d
Current message level: 0x000000ff (255)
Link detected: yes
[root@cubot3 root]#
----------------------------------------------

So, my problem arises when I try changing the setting to 1Gbps Full Duplex. When I do this, either the NIC doesn't get activated or it still shows me as 100Mbps Full Duplex. Have also tried putting a parameter in "/etc/rc.local" but it still remains the same.

Following parameter is being put into /etc/rc.local ---

ethtool -s eth1 autoneg off speed 1000 duplex full


This server has got another NIC which always remains deactivated. Have tried changing the network cables. Have also swapped the switch ports but no success. At times, either one NIC gets activated and other remains inactive or vice versa. I'm not able to figure out the problem as what it could be. Also, we have checked the swith side settings and they are proper.

Kindly suggest me what else can I try. Not able to locate the drivers as well.



TIA


Atul
2 REPLIES
Emir Faisal
Frequent Advisor

Re: Problem with NIC settings

Hi,
Probably you need to install the driver for broadcom instead the generic driver brought by the OS (tg3).
For HP hardware, we can use smartstart to install all linux driver for the server hardware. I don't know about Dell. Official broadcom site should be a good place to start.

Thanks,
EF
Everything is possible, if you don't know what you're talking about.
Hemmetter
Esteemed Contributor

Re: Problem with NIC settings

Hi Atul,

if you configure gigabit speed you should always set autoneg to ON!
thus:
$ ethtool -s eth1 autoneg speed 1000 duplex full

Did you doublecheck your switchport settings?

What are the error counters of your interface?



rgds
HGH