System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with WebAgents on Tru64 5.1B

Oliver Krehan
Occasional Contributor

Problem with WebAgents on Tru64 5.1B

Hi,

I have the following problem:

I've installed version 3.4 of the insight agents on our Tru64-system running 5.1b patchlevel7. I can access the login-page and I can also log-on myself as root. But when I try to open the web agents sub-page (.../WEBAGENT/INDEX.TPL) there are only some hieroglyphics shown. It doesn't matter from where I try to open the page, either remote or local, always the same. I checked the file INDEX.TPL and it seems to be okay (some Javascript inside).
I also tried to deinstall the version 3.4 to get the version which comes with the base installation (version 2.41). The same problem. So I suggest that there is something wrong with the initial installation of the agents.

Is this a known problem and if yes, what can I do?
Thanks for your help,

best regards
Oliver Krehan
1 REPLY
Josephus_Premkumar
Occasional Visitor

Re: Problem with WebAgents on Tru64 5.1B

Hi Oliver,
This problem is seen when the snmp community string does not match between /etc/snmpd.conf and /var/opt/CPQIMxxx/web/im/webagent/WEBAGENT.INI

The default community string used by Tru64 UNIX Insight Management Agents is "public". In case, the community string used for local ip address snmp access is changed from this default value, the same community string has to be added to WEBAGENT.INI.
For example,
if /etc/snmpd.conf has the entry,
community private 0.0.0.0 read
Then add an entry in /var/optCPQIMxxx/web/im/webagent/WEBAGENT.INI under section [AgentConfiguration] as given below,
IDS_SNMP_READ_COMMUNITY=private
(or IDS_SNMP_WRITE_COMMUNITY=private for write access)

You will have restart hpsmhd (in CPQIM340 kit) or insightd (in earlier kits).
#/sbin/init.d/hpsmhd stop
#/sbin/init.d/hpsmhd start

You may also refer to http://h30097.www3.hp.com/cma/docs/eng/tru64unx.pdf for additional info.

Thanks and Regards,
Prem.