System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with autofs on RedHat ES 4.0 Upgr 4

 
Sebastian Szewczyk
Frequent Advisor

Problem with autofs on RedHat ES 4.0 Upgr 4

Hello,

I have problem when I want to set autofs on RH ES 4.0 upgr 4.
I export filesystem form HP-UX machine (HP-UX 11.23 IA) for RH machines.

I have on RH mounted FS /usr/sap. OK. In directory /usr/sap I have folder trans. And I want to mount with autofs on that folder filesytsem from hp-ux machines -/usr/sap.trans. W
On machine RH I set on /etc/auto.master line like this:
/usr/sap /etc/auto.trans --timeout=60
and in auto.trans I set:
trans -rw hpix:/usr/sap/trans
and when I restart autofs I have in /var/log/messages information:
Apr 26 16:17:47 xsx autofs: automount startup failed
Apr 26 16:20:02 xsx autofs: automount shutdown succeeded
Apr 26 16:20:02 xsx automount[11939]: mount_autofs: already mounted
Apr 26 16:20:02 xsx automount[11939]: /usr/sap: mount failed!
Apr 26 16:20:02 xsx autofs: automount startup failed

Additionally when i mount this FA manually evrything is ok - but I want to use autofs with timeout 60 second.

Best regards
seboizm
10 REPLIES

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

You are using indirect map which tries to mount /usr/sap since its already a RH mouted FS autofs fails to mount it.

You can use some think like below in master map file:

/- /etc/auto.trans

and in auto.trans:

/usr/sap/trans -rw hpix:/usr/sap/trans

And then restart autofs with required timeout value

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

Sebastian Szewczyk
Frequent Advisor

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

I can try other maps like your suggestion>
I use map type /~ etc. on my nfs automounter in systems Tru64 and HP-UX i try first map like that on linux but not workink properly. I try this now and give answer if this workin or not?
Sebastian Szewczyk
Frequent Advisor

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

when I give your suggestion of map I have from server answer like this:

[root@xdc init.d]# ./autofs stop
Stopping automount: [ OK ]
[root@xdc init.d]# ./autofs start
Starting automount:
failed to load map: "/usr/sbin/automount --timeout=60 /~ fi[FAILED]auto.trans"

Amazing because i don't have parameter timeout in auto.master, my file auto.master
/~ /etc/auto.trans
and auto.trans
/usr/sap/trans -rw des:/usr/sap/trans

what's wrong?
Sebastian Szewczyk
Frequent Advisor

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

When I use map like read on my last post in /var/log/messages:

Apr 27 14:13:54 rod automount[23977]: bad map format: found indirect, expected direct exiting
Apr 27 14:13:54 rod autofs: automount startup failed

Best regards
seboizm

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

You are using /~ in the auto.master file
it should be /-

That means replace ~(tilde) with -(hypen)
Sebastian Szewczyk
Frequent Advisor

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

Hmmmm amazing i mistake but that don't have me answer because I change on /- an when I restart autofs I have something like that information:
[root@rinit.d]# ./autofs restart
Stopping automount: [ OK ]
Starting automount: No Mountpoints Defined [ OK ]
Sebastian Szewczyk
Frequent Advisor

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

I thinking anbout my autofs perhaps his version is - autofs-4.1.3-187 hmmm.
I don't know maybe this version have bugs?
what do you think. Give me some advice in that situation.

Best regards
seboizm

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

Its working for me on Tru64 box, my auto.master and direct map files as follows:

$ cat auto.master

/- /etc/auto.trans

$ cat /etc/auto.trans

/usr/sap/trans -rw server:/usr/sap/trans

I will check on my linux box, let's see what happens.

Please check whether autofs is using correct mastermap and directmap files once.

/etc/sysconfig/autofs

BTW you can mail this behaviour to autofs@linux.kernel.org
Sebastian Szewczyk
Frequent Advisor

Re: Problem with autofs on RedHat ES 4.0 Upgr 4

I habe default configuration on /etc/sysconfig/autofs like that:

# Define custom options in /etc/sysconfig/autofs
# Use LOCALOPTIONS for defining variables, e.g. OSREL
# Use DAEMONOPTIONS to define the unmount timeout
# Define UNDERSCORETODOT as 1 to convert
# auto_home to auto.home and auto_mnt to auto.mnt
# Mount options, e.g. rsize=8192, should go in auto.master or
# the auto_* map entry for a specific mount point
#
LOCALOPTIONS=""
DAEMONOPTIONS="--timeout=60"
LDAPAUTOMASTER=""
# UNDERSCORETODOT changes auto_home to auto.home and auto_mnt to auto.mnt
UNDERSCORETODOT=1
DISABLE_DIRECT=1
# Only source one master map if set to 1. This would mimic Sun behaviour.
# The default is 0 to maintain backwards compatibility.
ONE_AUTO_MASTER=0
# List of directories to be ghosted, separated by white space.
GHOSTDIRS=""
# Base DN to use when searching for the master map
BASEDN=
~