cancel
Showing results for 
Search instead for 
Did you mean: 

Pty Special File activation

Leonardo Parrino
Occasional Visitor

Pty Special File activation

i am using an RX 2660 - with O.S HP-UX 11i and i have the following problem.
Using the INSF command to increase the number of the PTYM & PTYS ( insf -d pty -n 300 ) - the system create all the request special files, but only 48 of them are usable ( linked ).

I found this limit of 48 described also in the explanation given on the manual for the insf command.
Now i need to activate the new created tty's.
Someone could tell me how is it possible activate them ?

12 REPLIES
RickT_1
Valued Contributor

Re: Pty Special File activation

You will have to add them to the /etc/inittab file to get them to be useful.

Rick
Rita C Workman
Honored Contributor

Re: Pty Special File activation

I generally increase these via the kernel parms (npty, nstrpty, nstrtel) change and it will create the device files and get things in order.

Unless I have misread what your trying to do.

/rcw
Bill Hassell
Honored Contributor

Re: Pty Special File activation

You completed the first step correctly. The first 48 are indeed linked but the rest of the device files are completely useable. The second step is to increase the kernel parameters npty, nstrpty and nstrtel. You need to increase all 3 parameters to 300. Use sam (or smh if you are running 11.31) to increase the values. Unfortunately, smh has broken more than a decade of dependability by allowing changes to be made to the pty kernel parameters but not automatically running insf.

Just a note: 11i is a meaningless description created by the marketing department. 11i defines any version of HP-UX starting with 11.11 and higher.


Bill Hassell, sysadmin
Rita C Workman
Honored Contributor

Re: Pty Special File activation

Thanks Bill...I hadn't noticed that with SMH and Itanium.

I'm not a regular user of it preferring CLI to make changes on Itanium, so I hadn't hit that.

Good to know..
Amit_Suchak
Advisor

Re: Pty Special File activation

Let me know i have already increased for same configuration of servers below settings
und. but still its resticting upto 78 sessions only
mtxexd4:/roothome 29 ] kctune nstrtel nstrpty npty
Tunable Value Expression
npty 4000 4000
nstrpty 1000 1000
nstrtel (now) 60 Default
(next boot) 200 200

I am going to boot it tommrrow 7 AM IST But still its not going to reoslve i think as yest i had changes npty & nstrpty then run below command insf -d tels -s 1000..
Stiil its restrciting to 78 sessions . Pls let me know
Steven E. Protter
Exalted Contributor

Re: Pty Special File activation

Shalom,

A reboot will also run insf -e which will create the new device files.

You can run this yourself, but still need to boot.

Do not run insf -e with Oracle ASM running. It will change permissions on the database containers and could down your database.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Bill Hassell
Honored Contributor

Re: Pty Special File activation

> npty 4000 4000
> nstrpty 1000 1000
> nstrtel (now) 60 Default (next boot) 200 200

Unless you know exactly which pty files will be used by each of your applications, make them all the same -- 4000 seems a bit high unless you plan on have several thousand users logon at the same time. Change the 3 kernel params to the same value, like 1000. Then you can either run insf or reboot to activate all the device files.


Bill Hassell, sysadmin
Amit_Suchak
Advisor

Re: Pty Special File activation

Hi,
after reboot & chaging all parametere to 1000 still users can not open xterms . it does not go beyond 81 sessions. Let me know anything need to be done further any other kernel parameter ned to change.

I have done reboot & run insf but still xterm does not go beyond 81 .. any idea

Thank & regards
Amit
Viktor Balogh
Honored Contributor

Re: Pty Special File activation

Hi Leonardo,

Do you have problems with logging in or is this another application for which you want to raise the number of ptys?

I'm asking this because I had problems with an old application. Created some more device files with insf but it didn't solve my problem. It turned out that this legacy application used the ptys directly from under /dev. insf created the new ones under the directory /dev/ptym. So I created hard links to wire the new device files under /dev manually and it solved my problem.

Maybe this helps you.

http://viktorbalogh.net/blog/hp-ux/hp-ux_sysadm/listing-used-ptys-on-hpux

Regards,
Viktor
****
Unix operates with beer.
Viktor Balogh
Honored Contributor

Re: Pty Special File activation

posted almost the same time like you..

>xterm does not go beyond 81
any error messages? start xterm from command line to catch error messages.
****
Unix operates with beer.
Amit_Suchak
Advisor

Re: Pty Special File activation

Hello viktor,

Actaully i am trying to open xterm from anpther xterm from humming bird Excced GUI application . so a that that after changing this 3 kerenel paramet to 1000 but still its stucks at 81 . so just want to know if anythng else also need to change.
now i have increased this paramet to 4000 so it may increst that xterm
kctune nstrtel nstrpty npty
Tunable Value Expression
npty (now) 1000 1000
(next boot) 4000 4000
nstrpty (now) 1000 1000
(next boot) 4000 4000
nstrtel (now) 1000 1000
(next boot) 4000 4000

Attached is the list of 62 users which ar elogging in . but when this reached 82 in in xterm hummimngbird exceed it gives error as below:-
xterm: Error 32, errno 16: Device busy
Reason: get_pty: not enough ptys xterm &
regards
Amit
Viktor Balogh
Honored Contributor

Re: Pty Special File activation