System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Quota Problem: quotaon error

 
Bruno Rebelo Lobato
Occasional Advisor

Quota Problem: quotaon error

I follow these steps to enable quota in my home users partition:

#cpset /dev/null /export/home/quotas 600 root bin

Then i enable quota for user blobato.
#edquota blobato

I Modify the line /etc/fstab like this
/dev/vgRAID1/lvolhome /export/home vxfs rw,suid,largefiles,delaylog,datainlog,quota 0 2

then i reboot my L2000 server.
But when the server come up, i saw my /etc/mnttab that the quota option not be active :
/dev/vgRAID1/lvolhome /export/home vxfs log,nodatainlog 0 0 1118322353

Then i try run :
#quotaon -v /export/home

but i received the following message :

quotactl: /dev/vgRAID1/lvolhome: I/O error

The most strange is, i have other partitions (vxfs) with quota running FINE, like you see in this output :
root : quotaon -av
/training: quotas turned on
/temp_teste: quotas turned on
quotactl: /dev/vgRAID1/lvolhome: I/O error

Can anybody help-me, please. I need to activate the quota on home users.

Thank's.

Bruno Lobato
Brazil - Amazon
18 REPLIES 18
RAC_1
Honored Contributor

Re: Quota Problem: quotaon error

Are there any problems with that lvol??
Check dmesg/syslog. mount -p | grep "lvol" Is lvol mounted with quota option??

Also make sure you correctly updated fstab. Also when you rebooted system, did you see anything wrong, any error messages for this lvol??

Anil
There is no substitute to HARDWORK
Victor BERRIDGE
Honored Contributor

Re: Quota Problem: quotaon error

Hi,
In your home directory you should find a file called quotas with perms rw only to root, is it there?
Then try:
Unmount /export/home
mount -o quota /dev/vgRAID1/lvolhome /export/home


Good luck
Victor
Bruno Rebelo Lobato
Occasional Advisor

Re: Quota Problem: quotaon error

## RAC ###
>> Are there any problems with that lvol??

No, the lvol is ok and working.

>> Check dmesg/syslog. mount -p | grep "lvol" Is lvol mounted with quota option??

The output off this command is the /etc/mnttab file, how i said in my post in the mnttab the quota option don't is showed but i set up the quota option in the /etc/fstab before boot my server.


>>Also make sure you correctly updated fstab.

Yes, please see :
/dev/vgRAID1/lvolhome /export/home vxfs rw,suid,largefiles,delaylog,datainlog,quota 0 2

Also when you rebooted system, did you see anything wrong, any error messages for this lvol??

No, everything is fine. with all the partions, but only in this i can't up the quota service :-(

### Victor ###

>> In your home directory you should find a file called quotas with perms rw only to root, is it there?

Yes, see :
-rw------- 1 root bin 0 Jun 9 15:25 quotas

>> Then try:
Unmount /export/home
mount -o quota /dev/vgRAID1/lvolhome /export/home

I can't umount my home partition at this moment, but when i try this :

mount -o remount,quota /dev/vgRAID1/lvolhome /export/home/
vxfs mount: cannot enable quotas

The point is, i have others partions in the same server, and in this other partitions the quota option works :-(.

Any other sugestions ?

Thank's.
RAC_1
Honored Contributor

Re: Quota Problem: quotaon error

fstype -v /dev/vgRAID1/rlvolhome

What does it say??
There is no substitute to HARDWORK
Bruno Rebelo Lobato
Occasional Advisor

Re: Quota Problem: quotaon error

>> fstype -v /dev/vgRAID1/rlvolhome

>> What does it say??

I don't know, thats is because i am under HPUX 11.00 , but i don't have this command :-(

Thanks.
Ermin Borovac
Honored Contributor

Re: Quota Problem: quotaon error

I/O error indicates problem with physical media. Find out what physical volumes are on this logical volume, then check if have any stale extents on each disk. You can also test disks by running dd on each disk device file and sending output to /dev/null.

# dd if=/dev/rdsk/cxtxdx of=/dev/null bs=64k
Bruno Rebelo Lobato
Occasional Advisor

Re: Quota Problem: quotaon error

>> I/O error indicates problem with physical media. Find out what physical volumes are on this logical volume, then check if have any stale extents on each disk. You can also test disks by running dd on each disk device file and sending output to /dev/null.

# dd if=/dev/rdsk/cxtxdx of=/dev/null bs=64k

All the extents are "current", and the dd command work's fine, whithout problems.

Any other sugestion ?

Thank's.
Robert-Jan Goossens
Honored Contributor

Re: Quota Problem: quotaon error

Bruno,

You are sure you are using quotas on a vxfs filesystem ?

# fstyp -v /dev/vgRAID1/rlvolhome

Did you try to use the quotacheck command ?

# qoutacheck -F vxfs -v /export/home

HTH,
Robert-Jan
Bruno Rebelo Lobato
Occasional Advisor

Re: Quota Problem: quotaon error

>> You are sure you are using quotas on a vxfs filesystem ?

>> # fstyp -v /dev/vgRAID1/rlvolhome

Yes, see the output :
root < MN >: fstyp -v /dev/vgRAID1/rlvolhome
vxfs
version: 3
f_bsize: 8192
f_frsize: 8192
f_blocks: 12800000
f_bfree: 1354612
f_bavail: 1354612
f_files: 266752
f_ffree: 1073792360
f_favail: 1073792360
f_fsid: 1073872897
f_basetype: vxfs
f_namemax: 254
f_magic: a501fcf5
f_featurebits: 0
f_flag: 16
f_fsindex: 6
f_size: 12800000

>>Did you try to use the quotacheck command ?

>># quotacheck -F vxfs -v /export/home
root < MN >: quotacheck -F vxfs -v /export/home
Syncing quotas for /dev/vgRAID1/lvolhome (/export/home)

The point is, i have others vxfs partitions in the same server, and in this other partitions the quota option works FINE:

root < MN >: repquota -av
/dev/vgRAID3/lvoltraining (/training):
Block limits File limits
User used soft hard timeleft used soft hard timeleft
blobato -- 0 120000 150000 0 400 500
smoraes -- 8 90000 100000 13 0 0
/dev/vgRAID9/lvolteste (/temp_teste):
Block limits File limits
User used soft hard timeleft used soft hard timeleft
blobato -- 0 120000 150000 0 400 500
/dev/vgRAID1/lvolhome (/export/home):
Block limits File limits
User used soft hard timeleft used soft hard timeleft

Any other sugestions ?

Thank's