System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

RHEL 5.4 X86_64 BL465C and Kernel problem with cciss

 
Roger Dodger
Occasional Visitor

RHEL 5.4 X86_64 BL465C and Kernel problem with cciss

Hello,

This problem involves the latest kernel for RHEL 5.4 which is kernel-2.6.18-238.el5.x86_64.rpm and the blade center BL465C G2 running an E200i controller. We upgraded the kernel using yum and it all worked normally with no issues. Then we booted the system using the new kernel. The /boot directory (which is the only physical parition other than swap as the rest are all LVM) now shows up as a USB device with a thumb drive icon. We tried things like removing the USB drivers, booting with the nousb option in the kernel Grub command. We even went so far as to shut off ACPI. None of that had any effect so we rolled the kernel back to the old one. We went back and forth between these 2 kernels and when we rolled back the USB drive disappeared when on the older kernel. Now, however, it appears no matter what, and even removing the new kernel completely we see a USB drive for /boot. The system runs fine and all that, but this is a hardening issue. We have to pass hardening scans and this looks from to a person scanning our machine as a USB device plugged into the blade server. I have not seen a driver fix for this issue like the cpq fixes HP releases from time to time as needed. I don't see any fix either, I am looking for guidence. Red Hat has some similiar but not exact problems posted in their bugzilla section, but nothing that is EXACTLY like this problem. Any help is much appreciated. Thank you!
1 REPLY
Matti_Kurkela
Honored Contributor

Re: RHEL 5.4 X86_64 BL465C and Kernel problem with cciss

From your description, it sounds like some desktop utility looks into /etc/fstab for user-mountable partitions, then checks some kernel attributes to see if it's USB drive or something else. Apparently some change in the kernel has affected these attributes, and now the desktop utility "thinks" /boot is a USB drive when it really isn't.

Since /boot is not really an USB device, it logically follows that removing the USB drivers has no effect.

You should look for updates for the gnome-mount RPM, or perhaps remove and reinstall it. This bug report seems to indicate the default settings of gnome-mount can get corrupted, causing strangeness with removable devices:
https://bugzilla.redhat.com/show_bug.cgi?id=234716

(You're trying to run a hardened system with GUI desktop enabled???)

MK
MK