System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

RHEL5.3 multipath and EVA 5000

JJ.CHIOU
Occasional Visitor

RHEL5.3 multipath and EVA 5000

I have a newly installed RHEL 5.3 on a DL585G2 with two QLogic HBA (QLA2300). I have 1 drive presented to this server from an EVA 5000. I have installed hp-fc-enablement-2009-03-30 as well as HPDMmultipath-4.3.0. I have rebooted the server and multipathd is running, but multipathing is not working correctly. Below is the output of the multipath -ll command. Does anyone know why it show [failed][faulty] next to each path to the EVA? What additional steps do I need to configure RHEL5.3 for EVA storage? thanks alot

:/root>multipath -ll
mpath1 (3600508b400102d910000d000006d0000) dm-2 COMPAQ,HSV110 (C)COMPAQ
[size=10G][features=1 queue_if_no_path][hwhandler=1 hp-sw][rw]
\_ round-robin 0 [prio=2][active]
\_ 1:0:1:2 sdac 65:192 [active][ready]
\_ 0:0:0:2 sdb 8:16 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 0:0:1:2 sdk 8:160 [failed][faulty]
\_ 1:0:0:2 sdt 65:48 [failed][faulty]
1 REPLY
Steven E. Protter
Exalted Contributor

Re: RHEL5.3 multipath and EVA 5000

Shalom,

Since the server is relatively old, I would check the firmware bios and the HBA firmware for updates.

You may be encountering a problem with the hardware interfering with multi pathing.

RHEL 4 document that may work for 5.3

http://www.redhat.com/docs/manuals/csgfs/browse/4.6/DM_Multipath/index.html

Potentially helpful doc:
http://www.redhat.com/archives/rhelv5-list/2007-September/msg00077.html

ITRC thread
http://forums11.itrc.hp.com/service/forums/questionanswer.do?admit=109447626+1248945122425+28353475&threadId=1202660

Deals with install, however the links inside deal with more topics.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com