cancel
Showing results for 
Search instead for 
Did you mean: 

RP4440 printers won't print

 
Peter Chuang
Frequent Advisor

RP4440 printers won't print

Hi Experts,

I have rp4440 running 11.11 test server. Set up 2 printers, pb and pc so far.

# lpstat -t
scheduler is running
no system default destination
device for pb: /dev/null
device for pc: /dev/null
pb accepting requests since May 17 16:17
pc accepting requests since May 18 08:54
printer pb is idle. enabled since May 17 16:27
fence priority : 0
printer pc is idle. enabled since May 18 08:54
fence priority : 0
#

When I wanted to print to those 2 printers nothing came out of it by using lp -dpb /tmp/outfile.txt

I went to /opt/hpnpl/bin/hppi to run #3 option Diagnostics, then #4 Print a test page to printer. If I used pb or pb printer name, it gave me error message saying pb: unknown printer. But if I used IP address of the printer then it took me to the next menu option and printed the test page.

Thanks for your help in advance.

Peter C
16 REPLIES
Pete Randall
Outstanding Contributor

Re: RP4440 printers won't print

How did you "Set up 2 printers"? Did you use hppi or lpadmin?


Pete

Pete
Peter Chuang
Frequent Advisor

Re: RP4440 printers won't print

Hi Pete,

I used hppi.
John Guster
Trusted Contributor

Re: RP4440 printers won't print

the printers are networking connected. You need add the entry in the /etc/hosts file to map the name to the IP of the printers.



Peter Chuang
Frequent Advisor

Re: RP4440 printers won't print

John,

I added 2 entries in /etc/hosts, but those 2 printers still did not print.

Do I need to restart lp spooler?
John Guster
Trusted Contributor

Re: RP4440 printers won't print

some trickies in using: /opt/hpnp/bin/jetadmin or /opt/hpnpl/bin/hppi
1. Is this printer connected to? Choose other
Option 1) Lp destination (queue) name [ABC_1], choose 1 to give destination name as ABC===notice here there is no "_1"
2. yes to bounce lpsched to enable this printer, exit the program
3. vi /etc/hosts to add this printerâ s name and IP.this step has to be done after the printer is added, not before.
Peter Chuang
Frequent Advisor

Re: RP4440 printers won't print

Yes, I did use hppi option 1, 1, then changed the printer name from _19 to pb and pc.

I did add 2 entries in /etc/hosts also.

# lp -d pb /tmp/tmp
request id is pb-14 (1 file)
#
# lp -d pc /tmp/tmp
request id is pc-15 (1 file)
#

No print out from either printers.

I noticed below that no system default destination..... Does it have anything to do with the problem?

# lpstat -t
scheduler is running
no system default destination
device for pb: /dev/null
device for pc: /dev/null
pb accepting requests since May 17 16:17
pc accepting requests since May 18 08:54
printer pb is idle. enabled since May 17 16:27
fence priority : 0
printer pc is idle. enabled since May 18 08:54
fence priority : 0
#
singh sanjeev
Trusted Contributor

Re: RP4440 printers won't print

please check the status :

hpnpadmin -vi
lpstat -o

IS port are open for connection :

remote :515
network :9100
Sanjeev Singh
Peter Chuang
Frequent Advisor

Re: RP4440 printers won't print

#hpnpadmin -vi pb

rp4440 is allowed access to pb

Location : Computer Room
Contact :

Card IP Address : pb (192.12.12.242)
Network Mask : 255.255.248.0
Default Gateway : not specified
Idle Timeout : 270 seconds

Uptime : 3 days, 9:33:52
Time Since Reconfig : 3 days, 8:08:19
Reconfig By : not specified
Connections Accepted: 960
Connections Denied : 0 (not on access list)
Connections Aborted : 3
Last Host : ??? (192.12.12.113)
Last Host TCP Port: 2011
Reason : unknown reason
singh sanjeev
Trusted Contributor

Re: RP4440 printers won't print

test connection for you network printer,

#telnet IP 9100

Or try re-creating the printer, with addqueue.
#addqueue -h IP -q -i 9998 -b off
Sanjeev Singh
Peter Chuang
Frequent Advisor

Re: RP4440 printers won't print

# telnet 192.12.12.242 9100
Trying...
Connected to 192.12.12.242.
Escape character is '^]'.
Peter Chuang
Frequent Advisor

Re: RP4440 printers won't print

What is "queuename" below that I should replace with?

Or try re-creating the printer, with addqueue.
#addqueue -h IP -q -i 9998 -b off
singh sanjeev
Trusted Contributor

Re: RP4440 printers won't print

you have mention pb and pc

means
edit your /etc/hosts

IP pb
IP bc

#addqueue -h pb -q pb -i 9998 -b off
Sanjeev Singh
Peter Chuang
Frequent Advisor

Re: RP4440 printers won't print

pb and pc already exists


# addqueue -h pb -q pb -i 9998 -b off
pb already exists
# addqueue -h pc -q pc -i 9998 -b off
pc already exists
#
singh sanjeev
Trusted Contributor

Re: RP4440 printers won't print

Peter first delete the printer config which you have crated:

#lpshut
#lpadmin -x
#lpsched
#addqueue -h -q -i 9998 -b off
Sanjeev Singh
Chandrahasa s
Valued Contributor

Re: RP4440 printers won't print

HI,

You try to delete configured printer through sam and reconfigure using sam.

In sam you need to mention remote server name as print server ip

Chandra
Peter Chuang
Frequent Advisor

Re: RP4440 printers won't print

I re-install the OS, then added printers. This time it worked.

Thanks for all your help.