System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

RP7420 in boot loop Please need help

 
Mark Nieuwboer
Esteemed Contributor

RP7420 in boot loop Please need help

Gent,
After a filesystem corruption the server had a panic.
now everytime with booting i get the next line and the server reboot again.

entry 0 - major is 64, minor is 0x2; start = 0, size = 40960000
Starting the STREAMS daemons-phase 1
Checking root file system.
log replay in progress
replay complete - marking super-block as CLEAN
Root check done.
Create STCP device files
Starting the STREAMS daemons-phase 2
$Revision: vmunix: vw: -proj selectors: CUPI80_BL2000_1108 -c 'Vw for CUPI80_BL2000_1108 build' -- cupi80_bl2000_1108 'CUPI80_BL2000_1108' Wed Nov 8 19:24:56 PST 2000 $
Memory Information:
physical page size = 4096 bytes, logical page size = 4096 bytes
Physical: 8360960 Kbytes, lockable: 6584372 Kbytes, available: 7572232 Kbytes

/sbin/ioinitrc:
/dev/vg00/lvol1: 60 files, 0 icont, 6650 used, 30716 free (132 frags, 3823 blocks)
: ioinit: Rebooting the system because /etc/ioconfig and /stand/ioconfig files are inconsistent
Shutdown at 03:29 (in 0 minutes)
System shutdown time has arrived

sync'ing disks (0 buffers to flush):
0 buffers not flushed
0 buffers still dirty

Closing open logical volumes...
Done

Cells have been reset (Boot Is Blocked (BIB) is not set).

what to do te get in single user mode.
and i tried hpux -is
15 REPLIES 15
RAC_1
Honored Contributor

Re: RP7420 in boot loop Please need help

Are you not able to boot into single user mode?? Interrupt the boot process. bo pri
interact with isl and on isl prompt, hpux -is

Once on single user mode, check the sizes of /etc/ioconfig and /stand/ioconfig. Should be same. If not rename /stand/ioconfig and reboot, that should build new ioconfig and server should boot.
There is no substitute to HARDWORK
Alex Lavrov.
Honored Contributor

Re: RP7420 in boot loop Please need help

After being in single user mode as explained here:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=695058

# ioscan -fnC ext_bus | egrep -v "H/W|==" | awk '{print $3,$1,$2}' > /root/infile

# mv /etc/ioconfig /etc/ioconfig.OLD

# mv /stand/ioconfig /stand/ioconfig.OLD

# ioinit -f /root/infile

If there are only "line ignored" messages from ioinit, then you are good to go and dont have to reboot the system

# mv /etc/ioconfig /etc/ioconfig.OLD

# mv /stand/ioconfig /stand/ioconfig.OLD

# /usr/sbin/shutdown -r -y 0

system will stop at ioinit prompt at bootup

ioinitrc) ioinit -f /root/infile -r


Alex.
I don't give a damn for a man that can only spell a word one way. (M. Twain)
Mark Nieuwboer
Esteemed Contributor

Re: RP7420 in boot loop Please need help

Sory but i can't come into single user mode.
I had single user mode and after manualy checking the filesystems and then go to init 1 i come in the loop. I can't get go in single user mode.

grtz. Mark
Mei Jiao
Respected Contributor

Re: RP7420 in boot loop Please need help

Hi Mark,

Are you able to go into Single-user mode at all?

Do you have any extra disk that you can install OS onto and save the dump from there?

If you ever able to boot-up, please check if you have this patch PHKL_32603 for HP-UX 11.11.

Best regards,
Mei
Alex Lavrov.
Honored Contributor

Re: RP7420 in boot loop Please need help

Do not issue "init 1". Stay in single mode and try to execute command I gave.

If some command is missing, try to mount /usr, /sbin/, /vat etc ...

Do not climb in init levels if it couses the problem.

Alex.
I don't give a damn for a man that can only spell a word one way. (M. Twain)
Mark Nieuwboer
Esteemed Contributor

Re: RP7420 in boot loop Please need help

Hi,

Couldn't boot in single user mode from pri path but i could boot in single user mode from alt path.

grtz. Mark
Mark Nieuwboer
Esteemed Contributor

Re: RP7420 in boot loop Please need help

Gents.

I didnt say it but it is a serviceguard cluster.
After i edit /etc/lvmrc from 1 to 0
and i edit /etc/rc.config.d/cmcluster from 1 to 0 i good come in init 1.
I'm know trying to find out why it happend.

grtz. mark
Mei Jiao
Respected Contributor

Re: RP7420 in boot loop Please need help

Hi Mark,

I guess as long as you're able to go into Single-user mode, don't go further.

Please try the steps that were given and see how it goes?

Best rgds,
Mei
Mark Nieuwboer
Esteemed Contributor

Re: RP7420 in boot loop Please need help

Started to init 1 no problem after a vgdisplay my system gets a panic
see attached document.
sorry to say but not go futher isn't a solution the server must run.

grtz. mark