System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Red hat 4.5 and installing driver FC2142SR

Azamat
Frequent Advisor

Red hat 4.5 and installing driver FC2142SR

hi, everybody

i`ve DL380G5 server, OS - RedHat 4 update 5 output of the #cat /proc/version
Linux version 2.6.9-55.ELsmp (brewbuilder@ls20-bc2-14.build.redhat.com) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)).

1. i installed hba (fc) cards - HP FC2142SR pci-e
2. downloaded drivers from hp.com ( http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=1143907&prodTypeId=12169&prodSeriesId=1809835&swLang=8&taskId=135&swEnvOID=2025 )
3. when i`m trying to install drivers, it gives error # rpm -i hp-lpfc-8.0.16.32-4.linux.rpm
error: Failed dependencies: gcc is needed by hp-lpfc-8.0.16.32-4.noarch Suggested resolutions: gcc-3.4.6-8.i386.rpm
How is it possible? Red Hat 4 update 5 has already included gcc-3.4.6-8

please , help me!!! i cann`t upgrade kernel, `cause this server in the production and programs ehich running on them can be damage
3 REPLIES
Ivan Ferreira
Honored Contributor

Re: Red hat 4.5 and installing driver FC2142SR

What is the output of rpm -qa | grep gcc?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Azamat
Frequent Advisor

Re: Red hat 4.5 and installing driver FC2142SR

i`ve installed gcc (up2date -i gcc), but now i`ve next issue :

#rmp -i hp-lpfc-8.0.16.32-4.linux.rpm

error: %post(hp-lpfc-8.0.16.32-4.noarch) scriptlet failed, exit status 1

Build of lpfc.ko did not succeed
Azamat
Frequent Advisor

Re: Red hat 4.5 and installing driver FC2142SR

problem resolved.

gcc-3.4.6-8
glibc-devel-2.3.4-2.36
glibc-headers-2.3.4-2.36
glibc-kernheaders-2.4-9.1.100.EL
kernel-smp-devel-2.6.9-55.EL (this one was missed, i`ve installed kernel-devel but my boot kernel is 2.6.9-55.ELsmp -- with smp!!!)