System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

RedHat Linux ES 4 and ML150 G6

angelo_gomez2001
Occasional Contributor

RedHat Linux ES 4 and ML150 G6

Hi All,

Recently acquired HP ML150 G6 and now trying
to install Red Hat Linux ES4.

I can't proceed with Linux installation it displays

"no appropriate device found"

the specs are:

PROCESSOR: INTEL® XEON® QUAD CORE PROCESSOR E5520 (2.26 GHZ, 8MB L3 CACHE, 80W, DDR3-1066, HT, TURBO 1/1/2/2) (CAPABLE UP TO TWO PROCESSOR)
CACHE MEMORY: INTEGRATED 1X 8 MB L3 CACHE
MEMORY: 4 GB (2 X 2 GB) PC3-10600E UNBUFFERED ADVANCED ECC MEMORY
NETWORK CONTROLLER: EMBEDDED HP NC107I PCI EXPRESS GIGABIT SERVER ADAPTER
STORAGE CONTROLLER: HP SMART ARRAY P410 CONTROLLER W/256MB CACHE RAID CONTROLLER (RAID 0/1/1+0/5/5+0)
HARD DRIVE: NONE SHIPS STANDARD
INTERNAL STORAGE (CAPABILITY ONLY): SAS: 4.0TB (4 X 1TB 3.5") MAXIMUM / SATA: 4.0TB (4 X 1TB 3.5") MAXIMUM
POWER SUPPLY: 460W NON-HOT PLUG, NON-REDUNDANT POWER SUPPLY (70% EFFICIENCY)
OPTICAL DRIVE: HP HALF-HEIGHT SATA DVD-ROM OPTICAL DRIVE

HP SC11XE U320 PCI-E HOST BUS ADAPTER


- The easy setup cd version 2.0

Has anybody successfully installed RedHat Linux 4 on this model?

Please help. Thanks.


Angelo



4 REPLIES
Michal Kapalka (mikap)
Honored Contributor

Re: RedHat Linux ES 4 and ML150 G6

hi,

check this support matrix from HP :

http://h18000.www1.hp.com/products/servers/linux/hplinuxcert.html

it should be working but there are some requirements for rhe kernel version.

*3Red Hat Enterprise Linux 4
For servers with dual core processors, Update 1 (2.6.9-11.EL kernel) or greater is required.

mikap
Matti_Kurkela
Honored Contributor

Re: RedHat Linux ES 4 and ML150 G6

Welcome to ITRC Forums!

> HARD DRIVE: NONE SHIPS STANDARD

Have you installed any hard disks?

> STORAGE CONTROLLER: HP SMART ARRAY P410 CONTROLLER W/256MB CACHE RAID CONTROLLER (RAID 0/1/1+0/5/5+0)

The SmartArray is a true hardware RAID controller. It must be configured to present the desired RAID set(s) as logical disk(s), or else the OS will not see any disks at all.

HP seems to support RHEL 4 ES on this model.
To make the installation as easy as possible, use the latest installation CD images available from the RedHat Network (RHEL 4 ES Update 8, or "RHEL 4.8" for short). Just login to RHN, and click on "Download software" in the left sidebar to find the CD images.

RHEL 4 might still require a driver disk: go to http://www.hp.com/go/support and select "Download drivers and software". Type in your model, i.e. "ML150 G6" and press Enter to start the search for drivers. On the next pages, confirm your server model if necessary and choose your OS (RHEL 4, either 32 or 64-bit version). Then you should reach the download page: see the group "Software - Driver Diskettes" to download the latest SmartArray driver for RHEL 4.

See the RedHat Installation Guide for information on how to use it during the installation procedure.

NOTE: HP still calls it a "Driver Diskette", but it can actually be an USB memory stick or a CD-ROM. Appropriately enough, RedHat calls it now a "Driver Media".

https://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/en-US/rhel-ig-x8664-multi-en-4/

See Appendix E.

MK
MK
Fadia Almarei
Super Advisor

Re: RedHat Linux ES 4 and ML150 G6

hi

if the hardware issues are OK , just use the latest RHEL ES4 update CD's to install (4.8) , this problem is a drivers problem and having the latest version will help. it happened with me before on another hardware types
fadia.marei
angelo_gomez2001
Occasional Contributor

Re: RedHat Linux ES 4 and ML150 G6

Hi All,

Michal, Matti, Fadia thanks for your replies and references.

Btw, I have a 160 gb SAS hard disk (hot pluggable, 1 tb).

Using the Easy Setup CD, we clicked the delete system option then proceeded to install
Red Hat Linux 5.0

The O.S was successfully installed. However,
our existing production server uses RH 4.0 and we would like use the same version as this
server is going to be used as a backup.

We plan to clone our Oracle Apps using RH5, if there are issues we would like to revert back to RH4.0.

Hopefully, it will work.

Thank you so much for your valuable tips.

Will update you if ever this will be successful.


Regards,


Angelo