System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Reg: Hpux nfs is not working if start /sbin/init.d/nfs.client start some errorq

sandilyan
Advisor

Reg: Hpux nfs is not working if start /sbin/init.d/nfs.client start some errorq


root@osshp13:/#/sbin/init.d/nfs.client start
starting NFS CLIENT networking

starting up the rpcbind
rpcbind already started, using pid: 621
starting up the BIO daemons
/usr/sbin/biod 16
exportfs error: frisk: unknown host
Reading in /etc/exports
starting up the Status Monitor daemon
rpc.statd already started, using pid: 24946
starting up the Lock Manager daemon
rpc.lockd already started, using pid: 24952
starting up the Automount daemon
/usr/sbin/automount -f /etc/auto_master
No Maps were specified
mounting remote NFS file systems ...
Permission denied
FAILURE CODE: 1
Mount failed! Possible local filesystem mount.
If local filesystem, then nfs.server will mount it.

mounting CacheFS file systems ...

root@osshp13:/#mount135.254.229.180:/shabadi/sandy
Permission denied

Please give me Solution
4 REPLIES
avizen9
Esteemed Contributor

Re: Reg: Hpux nfs is not working if start /sbin/init.d/nfs.client start some errorq

do you know your NIS master server hostname / IP address?

there are few possible reason,
1)need to update your /etc/auto_master file
with +auto.master or any specific mount point parameter.

2)try to bind your NIS master in /etc/rc.config.d/namesvrs with below line

YPSET_ADDR="IP-Address of you NIS-server"

3)make sure you are trying to start nis client service with root user.

let me know how it goes,
Aneesh Mohan
Honored Contributor

Re: Reg: Hpux nfs is not working if start /sbin/init.d/nfs.client start some errorq

Hi,

Please post
a) cat /etc/auto_master
b) # showmount -e 135.254.229.180


Aneesh


Ganesan R
Honored Contributor

Re: Reg: Hpux nfs is not working if start /sbin/init.d/nfs.client start some errorq

Hi,

Can you paste the /etc/exports from 135.254.229.180?
Best wishes,

Ganesh.
likid0
Honored Contributor

Re: Reg: Hpux nfs is not working if start /sbin/init.d/nfs.client start some errorq

Hy,

The Errors you are getting when starting the nfs.client,don't look like the cause of your problem, looks more like a perm problem on the nfs server side.

The errors look like:

exportfs error: frisk: unknown host
Reading in /etc/exports you have a host in your /etc/exports that your machine can't resolve.

mounting remote NFS file systems ...
Permission denied
FAILURE CODE: 1

You have automount configured on boot, in the /etc/rc.config.d/nfsconf:

AUTO_MASTER="/etc/auto_master"
AUTOFS=1
AUTOMOUNT_OPTIONS=""
AUTOMOUNTD_OPTIONS=""

And it fails to mount a nfs fs beacuse of perms

check with:

#showmount -e 35.254.229.180

an have a look what and to who is the server exporting.
Windows?, no thanks