cancel
Showing results for 
Search instead for 
Did you mean: 

Regarding the FTP

unixguy_1
Regular Advisor

Regarding the FTP

Hi Friends,

we are maintaining 11.11,11.23 & 11.31 version OS in HP-UX

iam not able to connect to the server through FTP.
i checked the ftpusers files in "/etc/ftpd".
that user is not availble,so user can able to connect the server FTP.

so please anyone give explain such a time what can do to resolve this type of problem.

and i need more details about "/etc/shells" file.

thanks in advance.

Regards,
Unixguy.



9 REPLIES
Ganesan R
Honored Contributor

Re: Regarding the FTP

Hi Unixguy,

As yourself identified, make sure that the users shell is listed in /etc/shells file. If not add the shell into /etc/shells.
ftpd daemon will accept the ftp connections only if the user shell is exist on /etc/shells file

Note that ftp access will be given to all the user by default.

If you could provide the error you are getting we can help you better.
Best wishes,

Ganesh.
Lijeesh N G_1
Respected Contributor

Re: Regarding the FTP

Hi,

FTP
=====

1) Chek /etc/inetd.conf file for the following entry,

#ftp stream tcp6 nowait root /usr/lbin/ftpd ftpd -l

If # is there, remove it for enabling the port and restart the inetd by
#inetd -c

2) Check entry in /etc/ftpd/ftpusers file for checking any restriction for users.


Regards,
LIJEESH N G
unixguy_1
Regular Advisor

Re: Regarding the FTP

HI Ganesan,

Actullay user is not availble in that ftpusers file,i chcked /etc/shells file ,
the user shells is there ,but still that user is not able to connect the server through FTP.

i checked some servers "shell" file

"/bin/ftpshell" type of shells is there in that /etc/shell file.
can you explain about that.

Regards,
Unixguy.



unixguy_1
Regular Advisor

Re: Regarding the FTP

If created any user the FTP access is default to all the version of HP-UX OS.

am i right?


Regards,
Unixguy.


Ganesan R
Honored Contributor

Re: Regarding the FTP

Hi Unixguy,

>>If created any user the FTP access is default to all the version of HP-UX OS.
am i right?<<

Yes.

>>"/bin/ftpshell" type of shells is there in that /etc/shell file.
can you explain about that.<<

Probably /bin/ftpshell could be a customized shell which will allow only ftp connections.
You can use any shell like inbuilt shell or customized shell. But the shell should be listed in /etc/shells.

See "man shells" for more details

Best wishes,

Ganesh.
Jineesh
Advisor

Re: Regarding the FTP


Hi unixguy,

do an FTP from the server to itself.

#ftp 0

Check does this work fine...?

enable the inetd logging in using inetd -l command and check the syslog entries after trying to do an FTP to the server.

Paste here the error message you are getting.

Suraj K Sankari
Honored Contributor

Re: Regarding the FTP

Hi,

Are you getting the ftp prompt ?
if not then 1st login to the box and try to do a ftp into local host then you will know ftp is open or not in your server.

Suraj
Steven Schweda
Honored Contributor

Re: Regarding the FTP

> iam not able to connect [...]

This is not a useful problem description. It
does not say what you did or what happened
when you did it.

> If you could provide the error you are
> getting we can help you better.

> Paste here the error message you are getting.

> Are you getting the ftp prompt ?

Perhaps there's a reason that everyone is
asking for the same information. Is there
some reason that you're not giving it?
Rita C Workman
Honored Contributor

Re: Regarding the FTP

Here's a thought.....not knowing your network though....

Is it possible that you can not ftp to that box, because your network person has blocked the ftp port so nothing (from anywhere) can ftp to the box, or maybe just from the IP range your coming from?
Try ftp-ing from a different subnet to that box and see what you get.
Or try asking the network guy if they maybe got over zealous with doing some port security tasks.

Like I said, just a thought,
Rita