cancel
Showing results for 
Search instead for 
Did you mean: 

Release the port 49152

 
GTFSpanneer
Frequent Advisor

Release the port 49152

Hi All,

Happy new year 2011

My application team asking to realease the port 49152 for use to application. but port is using root process.is it possible to relase the port.Please help .
#lsof -i tcp |grep 49152
cimprovag 2771 root 6u IPv4 0xe0000001b451aac0 0t0 TCP localhost:49152 (LISTEN)

postmaste 2789 sfmdb 6u IPv4 0xe0000001b451aac0 0t0 TCP localhost:49152 (LISTEN)

postmaste 2792 sfmdb 6u IPv4 0xe0000001b451aac0 0t0 TCP localhost:49152 (LISTEN)

postmaste 2793 sfmdb 6u IPv4 0xe0000001b451aac0 0t0 TCP localhost:49152 (LISTEN)

postmaste 2803 sfmdb 6u IPv4 0xe0000001b451aac0 0t0 TCP localhost:49152 (LISTEN)

postmaste 3494 sfmdb 6u IPv4 0xe0000001b451aac0 0t0 TCP localhost:49152 (LISTEN)

postmaste 3527 sfmdb 6u IPv4 0xe0000001b451aac0 0t0 TCP localhost:49152 (LISTEN)

postmaste 7499 sfmdb 6u IPv4 0xe0000001b451aac0 0t0 TCP localhost:49152 (LISTEN)

regards
RPS.
2 REPLIES
Shibin_2
Honored Contributor

Re: Release the port 49152

I am not sure, whether sfm uses this port.

You may check in your /etc/services to find out, whether this port is specifically defined for any application. If not defined, then ask apps team, whether they can use different port.
Regards
Shibin
Mounaam
Trusted Contributor

Re: Release the port 49152

Hi,

confirm with one of following commands if this port is hardcoded during pg build (--with-pgport=nnn):
# /opt/sfmdb/pgsql/bin/pg_config --configure
or
# /opt/psb/db/pgsql/bin/pg_config --configure

If you try to modify this port by setting a new one in /var/opt/sfmdb/pgsql/postgresql.conf, other products will no more work (evweb...).

With ProviderSvcsCore C.02.00.05(11.31), SFMDB B.07.02.02 (11.23)... postmaster is listening on port 10864.

Perhaps upgrading your system (update-ux) will resolve your problem.

Regards and happy new year.